Closed Bug 1786521 Opened 3 months ago Closed 3 months ago

Fix AppearanceValueAffectsFrames.

Categories

(Core :: Layout: Form Controls, defect)

defect

Tracking

()

RESOLVED FIXED
106 Branch
Tracking Status
relnote-firefox --- 105+
firefox-esr102 --- fixed
firefox105 --- fixed
firefox106 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

No description provided.

We had zero tests for this, and when I implemented the optimization to
avoid reframing in most cases I apparently swapped the arguments ;_;

Fix <input type=search> which suffered from the same issue, but we don't
ship by default.

The severity field is not set for this bug.
:TYLin, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(aethanyc)
Severity: -- → S3
Flags: needinfo?(aethanyc)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3f9fe7434610
Fix AppearanceValueAffectsFrames. r=TYLin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch

Given this was a regression which shipped and caused some compat issues, did we consider an uplift?

Regressed by: 1768155

I think this landed during the soft-freeze, but I guess the patch is trivial so if we're doing a dot-release, might as well.

Comment on attachment 9291148 [details]
Bug 1786521 - Fix AppearanceValueAffectsFrames. r=jfkthame,#layout

Beta/Release Uplift Approval Request

  • User impact if declined: See dupes
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Relatively simple fixup to dynamic appearance changes.
  • String changes made/needed: none
  • Is Android affected?: Yes
Attachment #9291148 - Flags: approval-mozilla-release?

Set release status flags based on info from the regressing bug 1768155

Comment on attachment 9291148 [details]
Bug 1786521 - Fix AppearanceValueAffectsFrames. r=jfkthame,#layout

Simple fix with a lot of new tests and a few dupe bugs filed now. Approved for 105.0.2 and 102.4esr.

Attachment #9291148 - Flags: approval-mozilla-release?
Attachment #9291148 - Flags: approval-mozilla-release+
Attachment #9291148 - Flags: approval-mozilla-esr102+

Added to the 105.0.2 release notes:

Fixed a bug causing some dynamic appearance changes to appear when expected

(In reply to Ryan VanderMeulen [:RyanVM] from comment #14)

Added to the 105.0.2 release notes:

Fixed a bug causing some dynamic appearance changes to appear when expected

Hi, should that read “to not appear when expected”, please?

(As written, it made me wonder how it could be a bug if it caused things to appear when expected.)

Good catch! I've updated the note and it should be live in the next 15-20min.

You need to log in before you can comment on or make changes to this bug.