Closed Bug 1787409 Opened 1 month ago Closed 1 month ago

Allow opening DevTools for an add-on when installing it remotely

Categories

(DevTools :: General, enhancement)

enhancement

Tracking

(firefox106 fixed)

RESOLVED FIXED
106 Branch
Tracking Status
firefox106 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This is to support the following request from webext cli tool:
https://github.com/mozilla/web-ext/issues/759

The idea is to show the DevTools for the add-on when running:

$ webext run --devtools

This will install the add-on and show the devtools for that add-on right away,
so that you don't have to go through about:debugging for this.

_buildTabs/_setInitialMeatballState wasn't awaited for.
So that preference front request might be pending when closing the toolbox too quickly in tests.

We should wait for all RDP requests to be completed before resolving Toolbox.open.

Depends on: 1787992
Assignee: nobody → poirot.alex
Status: NEW → ASSIGNED
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9285c88795e1
[devtools] Resolve toolbox's opening only once the meatball menu is updated. r=nchevobbe
https://hg.mozilla.org/integration/autoland/rev/8eab39068a3c
[devtools] Allow to open DevTools when installing an add-on remotely. r=nchevobbe,devtools-backward-compat-reviewers
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
Regressions: 1789245
Duplicate of this bug: 1332299
You need to log in before you can comment on or make changes to this bug.