Percentage height ignored for child inside table with table-layout:fixed

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: trelane, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
I was writing a page using IFRAME, and I find that the height and width of the
iframe specified in CSS aren't respected when the page loads.  However, they
*are* respected when the user changes tabs and comes back!

Attached will be images showing before and after changing tabs.

I moved my page in development to http://www.physics.uiowa.edu/~jpingeno, but
the server there is old and braindead, and serves css as text/plain, not
text/css.  Ah well.

I'll take the screen shots and attach them in a second.
(Reporter)

Comment 1

16 years ago
Created attachment 105392 [details]
Before changing tabs

Before changing tabs
(Reporter)

Comment 2

16 years ago
Created attachment 105393 [details]
After changing tabs

After changing tabs.  It took a couple of tries, but it eventually worked.  All
I did betwen pre- and post was change to a couple of different tabs.
resummarize
Summary: iframe size CSS attributes not respected until changing tabs! → CSS height and width on <iframe> ignored on initial reflow
(Reporter)

Comment 4

16 years ago
Did you want me to resummarize, or were you stating what you did?

Comment 5

16 years ago
I would assume the latter.
If you could attach a page here that exhibits the bug it would help a lot.  I
tried creating a simplistic testcase, but it worked fine.

what build are you using?
(Reporter)

Comment 6

16 years ago
The link I gave in the original post serves the content right; just not the
Content-Type.  :/  You could snag a copy of that and put it on a
standards-compliant web server or just snag it locally (after renaming things to
make it be CSS again.)

Comment 7

16 years ago
index.js is missing, needed for a testcase.

Comment 8

16 years ago
Created attachment 112914 [details]
testcase

the problem seems to only exist with an iframe in a table.

with linux trunk build 2003012722, the frame is initially displayed with a
height of ~100px although the table is the proper height.
When the window is resized, the iframe grows to fill the table.

Comment 9

16 years ago
marking NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: CSS height and width on <iframe> ignored on initial reflow → CSS height and width on <iframe> in a table ignored on initial reflow

Comment 10

16 years ago
weird, the frame never becomes 100% high for me
moz 2003030408/win98

Comment 11

14 years ago
*** Bug 248943 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
I can reproduce this on 2004052009.  I did manage to make a work around for this
bug by using getElementById.
Created attachment 168127 [details]
Testcase without iframe

It's not only with iframes. I think this happens with every child with a
percentage height inside a table with table-layout:fixed.
So I think a more correct summary would be something like this: "Percentage
height ignored for child inside table with table-layout:fixed"
Attachment #105392 - Attachment is obsolete: true
Attachment #105393 - Attachment is obsolete: true
Resummarizing and changing component.
Component: Layout: HTML Frames → Layout: Tables
Summary: CSS height and width on <iframe> in a table ignored on initial reflow → Percentage height ignored for child inside table with table-layout:fixed

Updated

14 years ago
Assignee: core.layout.html-frames → nobody
QA Contact: amar → core.layout.tables

Comment 15

14 years ago
*** Bug 278654 has been marked as a duplicate of this bug. ***
Fixed by the patch for bug 293761.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.