Closed Bug 1788666 Opened 2 years ago Closed 2 years ago

[QuickActions] The quickaction update button does not update firefox

Categories

(Firefox :: Address Bar, defect)

Firefox 106
Desktop
All
defect
Not set
normal

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox106 --- verified

People

(Reporter: cbaica, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached video quickaction update bug

Found in

  • Fx 106.0a1

Affected versions

  • Fx 106.0a1

Affected platforms

  • Windows 10
  • Ubuntu 22
  • macOS

Preconditions

  • Download and install a nightly build after the Aug 30th (just make sure it's not the latest nightly so it contains the patch from bug 1783862).

Steps to reproduce

  1. Launch Firefox.
  2. Trigger the update from Help -> About Nightly and wait for the update to be applied.
  3. Click the address bar and type 'update'.
  4. Click the update quick action button.

Expected result

  • Firefox is restarted and running the latest version.

Actual result

  • The update doesn't happen.

Regression range

  • Not a regression

Additional notes

  • Functionality should've been available after the implementation of bug 1783862.
Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8eec48796f0e
Change a way to restart browser. r=daleharvey
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch

The issue is verified fixed using one of the builds after the fix was applied on Windows 10 and Ubuntu 22.04. Clicking the 'Update Nightly' button after the download and application of the update is done, correctly restart Firefox.

Status: RESOLVED → VERIFIED
No longer blocks: 1838617
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: