Closed Bug 1783862 Opened 2 years ago Closed 2 years ago

Have UrlbarInterventions trigger appropriate action

Categories

(Firefox :: Address Bar, defect)

Firefox 105
Desktop
All
defect

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- unaffected
firefox104 --- unaffected
firefox105 --- disabled
firefox106 --- verified

People

(Reporter: aflorinescu, Assigned: daisuke)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Note

  • IMO, it comes as a surprise as under the guise of "quick actions", I'm opening sumo pages. It is unexpected that instead of performing an action, as an user I'm redirected towards a sumo page.

Found in

  • 105.0a1 (2022-08-09)

Affected versions

  • 105.0a1 (2022-08-09)

Affected platforms

  • Windows10

Steps to reproduce

  1. Open Nightly (quick actions enabled - default on Nightly 105)
  2. In a new tab type in address bar "clear", select and click on Clear History quick action.
  3. In a new tab type in address bar "refresh", select and click on Refresh Nightly quick action.

Expected result

  1. Clear History modal is opened.
  2. Refresh Nightly modal is opened.

Actual result

  1. Sumo is opened: https://support.mozilla.org/1/firefox/105.0a1/WINNT/en-US/delete-browsing-search-download-history-firefox
  2. Sumo is opened: https://support.mozilla.org/1/firefox/105.0a1/WINNT/en-US/refresh-firefox-reset-add-ons-and-settings

Regression range

  • N/A

Additional notes

  • In the same category also enters the Update quick action which has a SUMO as an action and where to my knowledge AFAIK most beef is with ophaned versions and annoyance for updates too often, so maybe that makes sense to be a SUMO.

I hadn't actually tried these quick actions, but after trying out the two use cases detailed here, this does feel pretty unexpected (and quick and dirty). I could have sworn that the older version of quick actions actually began a Firefox Refresh if users selected from the refresh Firefox prompt, which felt a lot more integrated.

Severity: S3 → S4
Has STR: --- → yes
Summary: Quickactions do not always direct user to actions → Have UrlbarInterventions trigger appropriate action

I was unaware the urlbar interventions triggered the actions as I glanced through the code and on a brief test I only seen the url open which looks like a fallback, refresh, update and clear all have actions that they may be able to trigger so we should do the same

Assignee: nobody → daisuke
Status: NEW → ASSIGNED

Depends on D155542

Attachment #9291478 - Attachment description: Bug 1783862: Open Sanitize dialog by claer action. → Bug 1783862: Open Sanitize dialog by clear action.
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1b560e670ff0
Open ResetProfile dialog by refresh action. r=daleharvey
https://hg.mozilla.org/integration/autoland/rev/a442c08ab22b
Open Sanitize dialog by clear action. r=daleharvey
https://hg.mozilla.org/integration/autoland/rev/467b4cdb0608
Update browser by update action if possible. r=daleharvey

The patch landed in nightly and beta is affected.
:daisuke, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox105 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(daisuke)
Flags: needinfo?(daisuke)
See Also: → 1783450

The issue is verified fixed using the latest Fx106.0a1 on Windows 10, macOS and Ubuntu 22. The buttons now correctly point to the intended actions.
Please note that the problem with the update button is addressed in bug 1788666. Clear history and Refresh work correctly.

Status: RESOLVED → VERIFIED
No longer blocks: 1838617
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: