Closed Bug 1790015 Opened 2 years ago Closed 2 years ago

Extension popups are misaligned when anchored to the unified extensions button

Categories

(WebExtensions :: Frontend, defect)

defect

Tracking

(firefox-esr91 unaffected, firefox-esr102 unaffected, firefox104 unaffected, firefox105 unaffected, firefox106 fixed)

RESOLVED FIXED
106 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox104 --- unaffected
firefox105 --- unaffected
firefox106 --- fixed

People

(Reporter: willdurand, Assigned: willdurand)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [addons-jira])

Attachments

(3 files)

Extension popups re-anchored in Bug 1784292 have slightly moved to the right (in LTR mode) after Bug 1788273. This is because we had a X offset set to 2, which does not seem to be needed anymore.

Component: XUL Widgets → Frontend
Product: Toolkit → WebExtensions

Set release status flags based on info from the regressing bug 1788273

We cannot fully remove popupOptions because that wouldn't position the popups correctly in RTL mode.

Pushed by wdurand@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e771b223d49
Re-align extension popups when anchored to the unified extensions button. r=rpl
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: