Closed Bug 1791657 Opened 1 year ago Closed 1 year ago

Page title is not shown for autofill result when the whole URL is typed into at once

Categories

(Firefox :: Address Bar, enhancement)

enhancement

Tracking

()

VERIFIED FIXED
111 Branch
Tracking Status
firefox111 --- verified

People

(Reporter: emk, Assigned: daisuke)

References

Details

Attachments

(2 files)

Steps to reproduce:

  1. Visit a URL (use https://bugzilla.mozilla.org/show_bug.cgi?id=1291573 as an example below) until autofill works.
  2. Copy https://bugzilla.mozilla.org/show_bug.cgi?id=129157 and paste it into the URL bar.
  3. Type 3 into the address bar.
  4. Page title is shown for autofill result.
  5. Copy https://bugzilla.mozilla.org/show_bug.cgi?id=1291573 and paste it into the URL bar.

Actual result:
The autofill result is https://bugzilla.mozilla.org/show_bug.cgi?id=1291573 - Visit. No page title is shown.

Expected result:
Page title should be shown for autofill result like the step 4 above.

I have to paste the URL, delete the last character, and type the last character again as a workaround.

Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Attachment #9295710 - Attachment description: Bug 1791657: Show page title if the pasted URL is in history." → Bug 1791657: Show page title if the pasted URL is in history.
Attachment #9295710 - Attachment description: Bug 1791657: Show page title if the pasted URL is in history. → Bug 1791657: Show page title if the pasted URL is in history."
Attachment #9295710 - Attachment description: Bug 1791657: Show page title if the pasted URL is in history." → Bug 1791657: Show page title if the pasted URL is in history.
Attachment #9298356 - Attachment description: WIP: Bug 1791657: Use payload.title as the web page title. → WIP: Bug 1791657: Introduce rawTitle into payload.
Attachment #9298356 - Attachment description: WIP: Bug 1791657: Introduce rawTitle into payload. → Bug 1791657: Introduce rawTitle into payload.
Attachment #9298356 - Attachment description: Bug 1791657: Introduce rawTitle into payload. → Bug 1791657: Introduce rawTitle, autofilled into payload.
Attachment #9295710 - Attachment description: Bug 1791657: Show page title if the pasted URL is in history. → Bug 1791657: Show page title and favicon if it is in history.
Attachment #9298356 - Attachment description: Bug 1791657: Introduce rawTitle, autofilled into payload. → Bug 1791657: Introduce fallbackTitle into payload.
Attachment #9295710 - Attachment description: Bug 1791657: Show page title and favicon if it is in history. → Bug 1791657: Show page title if it is in places.
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81475b006184
Introduce fallbackTitle into payload. r=adw
https://hg.mozilla.org/integration/autoland/rev/1d94f6f32328
Show page title if it is in places. r=adw,mak
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 111 Branch

I've managed to reproduce the issue using Fx 107.0a1.
The issue is verified fixed using the latest Fx 111.0a1 on Windows 10 and Ubuntu 22.04. When pasting the full link, the page title is correctly displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.