Closed Bug 1792277 Opened 2 months ago Closed 2 months ago

Sidebar doesn't correctly reflow when resized

Categories

(Firefox :: Theme, defect)

Firefox 107
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox105 --- unaffected
firefox106 --- unaffected
firefox107 --- verified

People

(Reporter: bloonyapprentice, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached video after.mp4

Steps to Reproduce

  1. Open any sidebar, for example Bookmarks panel with Ctrl+B.
  2. Resize the sidebar to the left or right.
  3. Observe the content of the sidebar.

Actual result

The sidebar content is stuck to the initial layout regardless of the space available.

Expected result

The sidebar content should adapt to the size of the sidebar like before.

Regression range

mozregression points to https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=dd74d4159c5dfa4307f663df24cf64766a4d5781&tochange=61cde6b6f2737eee00c49fb75390aff3d814f677, which is bug 1789168.

Notes

  • As you can see from the video, the sidebar no longer has a minimum or maximum width. This could be a plus for some people if they want an even smaller or bigger sidebar.
  • This impacts vertical tabs extensions like TreeStyleTabs, Sidebery etc
Attached video before.mp4

A screen recording of the behaviour before the regression for reference.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Regressed by: 1789168

Set release status flags based on info from the regressing bug 1789168

:emilio, since you are the author of the regressor, bug 1789168, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)
Assignee: nobody → emilio
Flags: needinfo?(emilio)

Add some basic min/max size support in splitters, and make the width
part of the element we're splitting rather than the <browser> child.

I don't think the nsSplitterFrame changes are needed for this in
particular, since we're only distributing across two items (min and max
are useful only if we can distribute the space that one item can't fill
with another), but it doesn't hurt.

Thanks for reporting this!

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97e0c3328eee
Fix sidebar resizing with flexbox emulation. r=Gijs,dholbert
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

Bug 1792299 was marked as duplicate, but it hasn't been fixed by this patch.

The remembering the width / height should be covered by bug 1792748

Flags: qe-verify+

I managed to reproduce this issue on a 2022-09-26 Nightly build on Windows 10 using the STR from the Description. Verified as fixed on Firefox 107.0b3(build ID: 20221020202724) and Nightly 108.0a1(build ID: 20221020215126) on Windows 10, macOS 12, Ubuntu 22.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.