Closed Bug 1792664 Opened 2 months ago Closed 2 months ago

Participants list is not properly shrinking to its available height

Categories

(Thunderbird :: Instant Messaging, defect)

defect

Tracking

(thunderbird_esr102 unaffected, thunderbird106 unaffected, thunderbird107 fixed)

RESOLVED FIXED
107 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird106 --- unaffected
thunderbird107 --- fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

The chat participants list is no longer shrinking to the available space in the window and instead takes up the entire height it needs, making it a couple thousand pixels high for some rooms. This leads to the entire chat conversation content layout flowing out the bottom of the window. I suspect this is related to the recent changes around the way flex works in XUL.

I tried to reproduce this in mozregression but couldn't get it to fail.

Flags: needinfo?(alessandro)

You'll need to check the corresponding m-c revisions.

Yes, obviously. I would assume this is caused by bug 1689816 though I don't quite understand how. I also wonder if this is at its core the same issue as bug 1783417. Since it seems our layout allows the tabpanels to get longer if one of the tabs just pushes hard enough, leading to all tabs being that height now.

Assignee: nobody → martin
Status: NEW → ASSIGNED
Regressed by: 1689816
Flags: needinfo?(alessandro)
Target Milestone: --- → 107 Branch

Pushed by martin@humanoids.be:
https://hg.mozilla.org/comm-central/rev/80daa5a4a30c
Fix chat tab contents overflowing window height. r=thunderbird-reviewers,Paenglab

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.