If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Enter followed by Backspace changes language from Hebrew to English in RTL textarea

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
P4
minor
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Yaron, Assigned: smontagu)

Tracking

({rtl})

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

When typing text in a textarea and the cursor is in Hebrew mode, if you press
enter and then backspace, the input language changes to English. Happens both in
RTL and LTR textareas.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Stay in Hebrew input mode.
this could be editor:core instead... cc'ing kin

Comment 2

15 years ago
Confirming on WindowsXP (2002110108)


I can also reproduce this in an Input field. Just type some Hebrew text then
press the left arrow key once.


Bug 162242 and Bug 163243 are also related.
(Assignee)

Comment 3

15 years ago
Confirming and taking. In an LTR textarea this is possibly not a bug, but it
shouldn't happen in RTL.

What is the exact case described in comment 2? Again, if the left arrow is
moving the cursor across LTR text (which includes a space between LTR and RTL
text if the textarea is LTR), then the input language is expected to change to
English.
Assignee: mkaply → smontagu
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

15 years ago
Sorry for not being more specific. I was referring to LTR Input field (or
textarea) with no mixed content. Now for RTL it's the exact opposite. Type an
English-only text (eg "foo") then hit the *right* arrow key. The result is an
unnecessary input switch to Hebrew/Arabic.

Those bugs I've mentioned are all similar, and deal with the same problem, IMHO.

Why is Mozilla constantly trying to switch the language input to match the
document's direction? The switching is quite annoying as it happens unexpectedly
and is almost always unnecessary (since it defeats the purpose of having an
input hotkey). The only exception that this auto switching is actually useful is
the case that you just mentioned in your comment.

Comment 5

15 years ago
Thamer:

> Why is Mozilla constantly trying to switch the language input to match the
> document's direction? The switching is quite annoying as it happens 
> unexpectedly and is almost always unnecessary (since it defeats the purpose 
> of having an input hotkey).

I can't agree with you more.

It seems that Mozilla is trying to mimic MS-Word and Wordpad, instead of IE, 
Notepad an almost every other Windows application.
The first two keep changing the input language in the most unexpected places, 
while the latter applications leave this control to the user.

In my opinion, this "feature" should be removed, although I'm not sure that 
this is the right bug...

Prog.

Comment 6

15 years ago
Mozilla also switches the language to English in the following scenarios:

1. Focus on an empty textarea and type a single Hebrew character.
2. Press Backspace twice.

Result: the language changes to English.


1. Using Hebrew input, focus on an empty textarea and type a digit, then space.
2. Press Backspace twice.

Result: the language changes to English (and even worse - the digit is not deleted).

Are these quirks mentioned in other Bugs?

The easiest solution to all of these bugs is to completely remove the
auto-language switch. Native Windows widgets don't have it, so why should
Mozilla have it's own standard?

BTW, this mechanism is not implemented in the BeOS version of Mozilla and the
result is a better experience for end-users (which is absurd really, unlike
Windows, BeOS doesn't natively support Hebrew...)

Prog.

Here are a couple of test URLs: 
Visual Hebrew: http://forums.ort.org.il/scripts/addform.asp?which_forum=30
Logical Hebrew:
http://www.mentor.org.il/mb/mentor/post.shtml

Updated

15 years ago
Depends on: 162242

Updated

15 years ago
Priority: -- → P4
Target Milestone: --- → Future

Comment 7

14 years ago
The solution? In my opinion, autodetect lang. mode, (bidiv),
or at least support manually on changing languages,
Force RTL or Force LTR with the CTRL+SHIFT like in MS Windows (TM).

Comment 8

14 years ago
> The solution? In my opinion, autodetect lang. mode, (bidiv),

You mean detect the currently used input method (HE/EN)? what will this
information be used for?

> or at least support manually on changing languages,

You can manually switch languages when using Mozilla, the problem is that
Mozilla also tends do it for you, when you don't expect it to.

> Force RTL or Force LTR with the CTRL+SHIFT like in MS Windows (TM).

This is Bug 98160 ("Can't change alignment/directionality in a textarea"), it is
not related to input method switching.

Prog.

PS.
You are welcome to continue this discussion in Mozilla Israeli forums:
http://mozilla.org.il/board

Comment 9

14 years ago
The fix for bug 162242 also solved this one. Marking as WORKSFORME.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040105

Prog.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.