[PP] Menu item Edit | Delete is now enabled but doesn't workd.

VERIFIED FIXED in M12

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: Suresh, Assigned: hangas)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Overview Description:  Edit | delete is disabled.

Steps to Reproduce:
1. Start Messenger.
2. Click Edit | Delete. Delete is disabled.

Actual Results:  Cannot able to click on 'delete'.

Expected Results:  Should be able to click on delete to delete a News msg.

Build Date & Platform Bug Found:
1999-11-03-13-M11, Windows.

Updated

19 years ago
Summary: NEWS: Edit | Delete is disabled. → Menu item Edit | Delete is disabled.

Comment 1

19 years ago
Using 11-04-08 build, the menu item is enabled but doesn't work.  The menu item
doesn't work for mail messages, either.  This is a generic menu item problem,
not particular to news.

Remember when verifying: the Delete BUTTON should not work to cancel a news
message, only menu item (which should change to Cancel message - bug #8293).

Changed summary.

Updated

19 years ago
QA Contact: lchiang → esther

Updated

19 years ago
Summary: Menu item Edit | Delete is disabled. → [PP] Menu item Edit | Delete is disabled.

Comment 2

19 years ago
Happens with NT 4.0 and linux on 11-04-08 builds, but not on Mac.
Status: NEW → ASSIGNED
Target Milestone: M12
laurel, that's probably because mac menu code differ from the XP menu code that
linux and winnt uses.

accepting. marking m12.
Assignee: sspitzer → hangas
Status: ASSIGNED → NEW
re-assigning to hangas.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Target Milestone: M12 → M11
(Assignee)

Comment 5

19 years ago
Fixed with a checkin tonight.  Should work fine all all platforms now.

Updated

19 years ago
Status: RESOLVED → REOPENED
Summary: [PP] Menu item Edit | Delete is disabled. → [PP] Menu item Edit | Delete is now enabled but doesn't workd.

Comment 6

19 years ago
Using build 19991109M1 on win98 this is still a bug, however the summary needs
to change since the bug has changed from menu item Delete being disabled to
menu item Delete not working on Win and linux only.  Reopening and changing the
summary.  Note: work around for Mail messages is to use the Toolbar delete
button, but News has no workaround but is logged as a separate bug (18449).

Updated

19 years ago
Resolution: FIXED → ---

Updated

19 years ago
Target Milestone: M11 → M12

Comment 7

19 years ago
The toolbar button seems to work for me, so pushing this menu stuff to M12 where
we have a hope of actually fixing focus-related bugs.
(Assignee)

Updated

19 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Comment 8

19 years ago
This is a focus issue.  Saari has some focus fixes landing in M12 that may get
this working again.
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

18 years ago
This has been fixed through a focus checkin by saari and some style checkins I
made today.

Comment 10

18 years ago
Using build 1999112108 on linux this is fixed for both a mail message and a news
message, Windows can't be tested until a build later than 1999111909 comes out
because the warning dialog is squished and you can't answer "Yes" to the
warning.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 11

18 years ago
Using win32 build dated 1999112209m12 this is working now, the header is still
in the Thread pane, but when selected you get a message stating "No such
article".  Finally verfied.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.