Closed Bug 1795650 Opened 2 years ago Closed 9 months ago

The colors of the icons from the status bar are not in contrast with the status bar background color

Categories

(Fenix :: General, defect)

All
Android
defect

Tracking

(firefox117 wontfix, firefox118 wontfix, firefox119 verified)

VERIFIED FIXED
119 Branch
Tracking Status
firefox117 --- wontfix
firefox118 --- wontfix
firefox119 --- verified

People

(Reporter: iorgamgabriel, Assigned: giorga)

References

(Blocks 1 open bug)

Details

(Whiteboard: [qa-triaged])

Attachments

(5 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36

Steps to reproduce:

  1. From Gmail open a link on a custom tab or open a custom tab from Focus itself.
  2. The icons from status bar are not visible for light theme and for dark theme are not in contrast .
    This bug it is in Focus and Fenix . 106 version
    It was added first here https://github.com/mozilla-mobile/focus-android/issues/7860

Actual results:

The icons from status bar are not visible for light theme and for dark theme are not in contrast .

Expected results:

The colors of the icons from the status bar should be in contrast with the status bar background color.

The problem is in Android Component support-ktx modul WindowInsetsControllerCompat should be different than the status background color.

I can confirm this, version info:
106.1.0 (Build #2015909131), 71ca6c1f7+
AC: 106.0.5, 5f06485fc3
GV: 106.0-20221010181815
AS: 94.2.1

I use the light theme and the icons are white on white.
Switching to another tab and back fixes this: the text colour turns dark grey.
Switching to another app and back to Firefox brings back white on white.

It seems there is a check to define the notification bar text color that is executed correctly when switching between tabs, but it is skipped when Firefox becomes the active app.

The severity field is not set for this bug.
:cpeterson, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(cpeterson)
Severity: -- → S3

(In reply to Iorga Gabriel from comment #5)

This bug was fixed https://github.com/mozilla-mobile/focus-android/issues/7860

If not using dark mode, it will be fixed.

Unfortunately, I can reproduce same issue on Twitter's PWA when using the latest version of Firefox Nightly (on Pixel 6a + Android 13) with dark mode. Twitter's manifest.json has theme_color: "#ffffff", so background color of status bar is white. But status icon keeps white. I guess that this may be a bug of custom tab feature in android framework.

See Also: → 1813875
Flags: needinfo?(cpeterson)
Duplicate of this bug: 1797918
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached image Untitled.png

I was able to reproduce this on all the latest versions of Firefox: Nightly 118.0a1 from 8/25, Beta 117.0b9, and RC 117.0, with multiple devices: Google Pixel 6 (Android 14), and Samsung Galaxy Note 8 (Android 9).

Assignee: nobody → mlobontiuroman
Whiteboard: [qa-triaged]
Assignee: mlobontiuroman → giorga

On a side note if custom tabs toolbar getting site color then why not possible in main browser toolbar?

Worth noting this is a 3+ year old issue https://github.com/mozilla-mobile/fenix/issues/12488

Status: NEW → ASSIGNED

Authored by https://github.com/iorgamgabriel
https://github.com/mozilla-mobile/firefox-android/commit/409f99f5a58cfe9de7245f46768ad09f057dfbeb
[main] Bug 1795650 - Status bar and navigation bar colours should be the same, like toolbar colours.

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Flags: qe-verify+
Resolution: --- → FIXED
Target Milestone: --- → 119 Branch
Attached image Untitled.png

Verified as fixed on the latest Fenix Nightly 119.0a1 from 9/19 with the following devices:

  • Xiaomi Mi8 Lite (Android 12), and
  • Google Pixel 6 (Android 14).
Status: RESOLVED → VERIFIED
Flags: qe-verify+

The patch landed in nightly and beta is affected.
:giorga, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox118 to wontfix.

For more information, please visit BugBot documentation.

Flags: needinfo?(giorga)
Flags: needinfo?(giorga)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: