Closed Bug 1797548 Opened 1 month ago Closed 1 month ago

Move Unified Extensions panel out of the AppMenu panelmultiview and into its own

Categories

(WebExtensions :: Frontend, task)

task

Tracking

(firefox108 fixed)

RESOLVED FIXED
108 Branch
Tracking Status
firefox108 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

According to willdurand, the current Unified Extensions panel was created as a subview of the AppMenu mainly out of convenience, as it allows us to quickly stand up a new panel that is styled properly.

There are a few problems though:

  1. The way that the AppMenu subview panels work, is that once the panel closes, the subviews get thrown back into the AppMenu subview cache. That means if we have any overflowed addon widget nodes in there after bug 1797155 lands, then we'll need to update a number of places in CUI to get those nodes from the cache, which is kind of awkward.
  2. The temporary panel that gets created for AppMenu subviews ends up being a child of the nav-bar <toolbar>, which ends up having us inherit this rule: https://searchfox.org/mozilla-central/rev/59f0bf3c13dd455d9f5415b89178de701ea6b850/toolkit/content/xul.css#144-148, which hides the labels of the overflowed items. We could override that, but it feels awkward.

In general, especially considering how old the OverflowableToolbar code is, and how long it's been part of CustomizableUI, I'm inclined to make the Unified Extensions panel as close in behaviour and properties as the existing widget-overflow panel, to try to avoid weird behaviours when the panel closes and the subview goes back into the AppMenu view cache.

cc'ing Gijs, since I believe you were working with willdurand when this panel first got stood up.

Blocks: 1797155
No longer blocks: 1777480

(In reply to Mike Conley (:mconley) (:⚙️) from comment #0)

I'm inclined to make the Unified Extensions panel as close in behaviour and properties as the existing widget-overflow panel, to try to avoid weird behaviours when the panel closes and the subview goes back into the AppMenu view cache.

This approach seems like the right one to me, fwiw.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58f9f4ddf090
Move Unified Extensions panelview into its own dedicated lazily created panel. r=cmkm,willdurand
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
Regressions: 1798702
You need to log in before you can comment on or make changes to this bug.