Closed Bug 1797696 Opened 1 month ago Closed 23 days ago

SeaMonkey crashes on MacOS Ventura 13.0

Categories

(SeaMonkey :: General, defect)

Unspecified
macOS
defect

Tracking

(seamonkey2.53+ fixed)

RESOLVED FIXED
Future
Tracking Status
seamonkey2.53 + fixed

People

(Reporter: evs, Assigned: frg)

References

Details

(Whiteboard: SM2.53.15)

Crash Data

Attachments

(5 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36

Steps to reproduce:

Trying to run SeaMonkey

Actual results:

Application crashes

Expected results:

Application should run

I have the same experience after Ventura install this AM.

Same for me (using SeaMonkey 2.53.14)

Duplicate of this bug: 1798019
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → macOS
Version: Production → Trunk

Same for me (using SeaMonkey 2.53.14)

SeaMonkey 2.53.14 crashes immediately upon launch. (Ventura 13 on MacBook Air M2.) Have to use webmail for all my email until further notice.

SeaMonkey 2.53.14 crashes since update to macOS Ventura, running on intel iMac (2017). Upon double-clicking app, Mozilla Crash Reporter immediately appears with choices to share feedback, quit, or restart; following through with any one of those choices does not fix the problem. Frustrating since SeaMonkey is "home base" for email and browsing. Appreciate any updates, and look forward to seeing this resolved.

JT's "Comment 6" above, about running on intel iMac (2017), also describes my problem, but running on Apple silicon M1 Pro (2021)

How can this be upgraded to a S1 or S2 Severity? Worldwide Apple users are updating to Ventura (which was released a few days ago) and SM 2.53.14 won’t run in Ventura. I have searched everywhere to figure out who higher in the SeaMonkey chain of management and development should know about and tackle this critical bug.. I just don’t know where to pass this problem on to. I’m afraid that these comments are lost in the vast Bugzilla sea of reported (minor by comparison) bugs.

They are not lost. Just nothing which indicates where the problem is. No crash dump no terminal output. For all I know it might even be an Apple bug. Given the initial problems with at least 10.15 and 11 I made a habit of not updating till the .1 release is out.

Same here for 2.5.14

Crash Signature: bp-5097a170-47e4-40a6-9fb9-4f41f0221104

(In reply to Frank-Rainer Grahl (:frg) from comment #9)

They are not lost. Just nothing which indicates where the problem is. No crash dump no terminal output. For all I know it might even be an Apple bug. Given the initial problems with at least 10.15 and 11 I made a habit of not updating till the .1 release is out.

Thank you for your feedback. Nothing had changed on the status or priority levels at the top of the bug listing for days so didn’t know what developer action was going on with it.

AdapterDeviceID: 0x7340
AdapterVendorID: 0x1002
BuildID: 20220924171618
CrashTime: 1667626343
FramePoisonBase: 9223372036600930304
FramePoisonSize: 4096
InstallTime: 1664592986
Notes: FP(D00-L1000-W00000000-T000) AdapterVendorID: 0x1002, AdapterDeviceID: 0x7340WR? WR- OMTP? OMTP-
ProductID: {92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}
ProductName: SeaMonkey
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 99
StartupCrash: 1
StartupTime: 1667626342
ThreadIdNameMapping: 5:"Gecko_IOThread",6:"Socket Thread",7:"JS Watchdog",21:"BGReadURLs",22:"Hang Monitor",23:"Cache2 I/O",24:"Timer",25:"StreamTrans #1",30:"IPDL Background",31:"ImgDecoder #1",32:"ImgDecoder #2",33:"ImgDecoder #3",34:"ImgDecoder #4",35:"ImgDecoder #5",36:"ImgDecoder #6",37:"ImgDecoder #7",38:"ImgDecoder #8",39:"ImgDecoder #9",40:"ImgDecoder #10",41:"ImgDecoder #11",42:"ImgDecoder #12",43:"ImgDecoder #13",44:"ImgDecoder #14",45:"ImgDecoder #15",46:"ImageIO",47:"Compositor",48:"VRListener",
Throttleable: 1
UptimeTS: .57540923
Vendor: Mozilla
Version: 2.53.14

This report also contains technical information about the state of the application when it crashed.

The dump is unfortunately missing information. It looks like an early startup crash (surprise). The upcoming 2.53.15b1 will not fix it. The addtional patches in 2.53.16b1 pre which fixed the Firefox crashes in 13 did not help either. We are still keeping compatibility with 10.9 and up and use an older sdk. Need to try building with a later one and see what goes.

Given Ventura's new iOS-ish System Settings interface, I'm beginning to wonder if this has something to do with the Privacy & Security toggles, such as "Allow applications downloaded from…" and the choice of App Store or App Store and identified developers. I seem to recall, way back when, side-loaded apps such as Firefox or SeaMonkey for example, would fail to load even if "App Store and identified developers" was chosen, you then had to go in there and manually permit it. Not certain this is part of the problem, speculating only. Hope this gets resolved soon.

2.53.7.1 does a partial launch i.e. window frame is drawn with Welcome to SeaMonkey as it's title but doesn't get any further

Launching from Terminal
Last login: Sat Nov 5 10:41:18 on ttys000
/Applications/SeaMonkey\ 2.53.14.app/Contents/MacOS/seamonkey ; exit;
stepheniremonger@StephendState5K ~ % /Applications/SeaMonkey\ 2.53.14.app/Contents/MacOS/seamonkey ; exit;
2022-11-05 10:43:12.790 seamonkey[1153:21005] *** WARNING: Textured window <ToolbarWindow: 0x10a9f5800> is getting an implicitly transparent titlebar. This will break when linking against newer SDKs. Use NSWindow's -titlebarAppearsTransparent=YES instead.

Dump seems to be empty. The minidump analyser complains with a "no threads" error as seen in the extra file.

As a last resort try input_event_queue.supported set to false. Only thing recently added but working under 12.6.1
The warning is shown in 12.6 already and this works.

Recent releases have a broken fullscreen button at least on the M1 but on first glance unrelated to the Ventura problem.

To answer a Q earlier, I have the same problem with Seamonkey on MacOS 13.0 and tried to whitelist or approve it outside of the normal way with Apple support on the phone. It did not give the same error, but failed instantly when it tried to load the app...it would not open. Is there a way to fix the composer earlier than the rest of Seamonkey for those of us who are not coders but use the WYSIWYG capability of Seamonkey? I have not been successful in finding an alternative to edit a website. Thanks

Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Whiteboard: SM2.53.15

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: macOS 13 = crash
Testing completed (on m-c, etc.): 2.53.16b1 pre
Risk to taking this patch (and alternatives if risky): beta is done and some other backports needs but lets call it low risk becuase tested ok.
String changes made by this patch: --

Attachment #9302416 - Flags: review?(iannbugzilla)
Attachment #9302416 - Flags: approval-comm-release?

Drive by fix for version detection. For all branches including comm-central.
[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: Version detection not working for later macOs releases.
Testing completed (on m-c, etc.): 2.53.16b1 pre
Risk to taking this patch (and alternatives if risky): ua changes to actual macOS version but tested with various sites and ok.
String changes made by this patch: --

Attachment #9302417 - Flags: review?(iannbugzilla)
Attachment #9302417 - Flags: approval-comm-release?
Attachment #9302417 - Flags: approval-comm-esr60?

Tried: Please try https://archive.mozilla.org/pub/seamonkey/nightly/2022/11/2022-11-07-10-45-00-comm-253/seamonkey-2.53.16b1pre.en-US.mac.dmg
and it finally loaded the Seamonkey page after whitelisting it, but came up with this error: Sorry for the formatting. Would not paste graphic so had to "grab text"
1 SeaMonkey

     Home » Page Not Found



                                                                             Page Not Found

Home

                                                                            We're sorry, but we can't find what you're looking for.

News

                                                                             The page or file you're looking for wasn't found on our site. It's possible that you clicked a link that's ou

Download and Releases incorrectly.

Community and Support • If you typed in the address, please double check the spelling.

                                                                                   • If you followed a link from somewhere, please let us know at webmaster@seamonkey-project.org

Documentation and Help what you were looking for, and we'll do our best to fix it.

                                                                            Or you can just jump over to some of the popular pages on our website.Add-Ons

                                                                                   • Were you looking for our downloads?

SeaMonkey Shop
• Or maybe information about the SeaMonkey proiect?

                                                                                   • It might just be best to start at the SeaMonkey Home Page.

Donate

(In reply to Jim in Georgia from comment #25)
What's the URL that you entered? Is it spelled correctly?

(In reply to ljcool2006 from comment #26)

(In reply to Jim in Georgia from comment #25)
What's the URL that you entered? Is it spelled correctly?

For me, accessing any HTTPS website, including Yahoo or Google, results in Error code: SEC_ERROR_UNKNOWN_ISSUER

Comment on attachment 9302416 [details] [diff] [review]
TOP-1797696-macos11sdk-25316.patch

[Triage Comment]
r/a=me

Attachment #9302416 - Flags: review?(iannbugzilla)
Attachment #9302416 - Flags: review+
Attachment #9302416 - Flags: approval-comm-release?
Attachment #9302416 - Flags: approval-comm-release+

Comment on attachment 9302417 [details] [diff] [review]
1797696-macosver-25315.patch

[Triage Comment]
r/a=me

Attachment #9302417 - Flags: review?(iannbugzilla)
Attachment #9302417 - Flags: review+
Attachment #9302417 - Flags: approval-comm-release?
Attachment #9302417 - Flags: approval-comm-release+
Attachment #9302417 - Flags: approval-comm-esr60?
Attachment #9302417 - Flags: approval-comm-esr60+

(In reply to spoon.reloaded from comment #27)

(In reply to ljcool2006 from comment #26)

(In reply to Jim in Georgia from comment #25)
What's the URL that you entered? Is it spelled correctly?

For me, accessing any HTTPS website, including Yahoo or Google, results in Error code: SEC_ERROR_UNKNOWN_ISSUER

I used the one given to me to try and copy/pasted it. Here is what I tried:
https://archive.mozilla.org/pub/seamonkey/nightly/2022/11/2022-11-07-10-45-00-comm-253/seamonkey-2.53.16b1pre.en-US.mac.dmg
Perhaps it is the wrong one, I don't know

UPDATE: I reloaded the file and downloaded it to my Mac and it launched and it worked !!

THANK YOU TO ALL.
I know this is a patch, and I really appreciate it. How will I know it is safe to use a new version that incorporates this fix?

BRILLIANT! It works a treat:-
Details are here:-
Seamonkey
https://www.seamonkey-project.org/
version 2.53.16 beta 1 pre

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 13.0; rv:91.0) Gecko/20100101 Firefox/91.0 SeaMonkey/2.53.16
Build identifier: 20221107104500

https://archive.mozilla.org/pub/seamonkey/nightly/2022/11/2022-11-07-10-45-00-comm-253/seamonkey-2.53.16b1pre.en-US.mac.dmg

indeed works after allowing in Privacy & Security since sees it as from an unidentified developer. Thanks all!

Down loaded the beta pre release and launched successfully. After a few minutes crashed. Unrelated to the original issue I'm sure but I don't have any explicit steps to reproduce for now. Attach stack as seamonkey-2.53.15b1pre 2022-11-08 crash in case it is of some use.

File referenced in comment #33

Confirmation that I have downloaded this beta pre-release and it works ! Macbook M1 / Ventura

I installed this build [1] and confirm it works on macOS 13.1 (22C5044e) Beta 2 on an Apple Silicon machine.

[1] https://archive.mozilla.org/pub/seamonkey/nightly/2022/11/2022-11-07-22-00-01-comm-253/

Has anybody tested any current or forthcoming versions on 13.0.1? Does that version fix anything?

(In reply to JT from comment #38)

Has anybody tested any current or forthcoming versions on 13.0.1? Does that version fix anything?

Can confirm that macOS 13.0.1 on Intel still crashes, no change to behavior when running v. 2.53.14.

Can confirm that 2.53.16 beta 1 pre still run fine on macOS 13.0.1.

(In reply to JP from comment #40)

Can confirm that 2.53.16 beta 1 pre still run fine on macOS 13.0.1.

Thank you, JP, for the follow-up. Does run fine mean 2.53.16 beta 1 and any/all extensions (and/or plug-ins) are fully operational?

(In reply to JT from comment #41)

(In reply to JP from comment #40)

Can confirm that 2.53.16 beta 1 pre still run fine on macOS 13.0.1.

Thank you, JP, for the follow-up. Does run fine mean 2.53.16 beta 1 and any/all extensions (and/or plug-ins) are fully operational?

My extensions seem to be working.

Facebook and Linkedin are broken.

(In reply to JT from comment #41)

(In reply to JP from comment #40)

Can confirm that 2.53.16 beta 1 pre still run fine on macOS 13.0.1.

Thank you, JP, for the follow-up. Does run fine mean 2.53.16 beta 1 and any/all extensions (and/or plug-ins) are fully operational?

I run limited extensions but ones I used in 2.53.14 before Ventura are no problem. Zero crashes or hangs in browser, email, composer, address so far.

Thank you for the follow-up neoknight95 & JP. Further inquiries below.

  1. neoknight95, are the FB and LinkedIn "breakages" due to the browser, an app issue?
  2. Or do you believe it's a network, server-side problem?
  3. Secondly, if FB is not working, what about Meta's other product, Instagram?
  • JP, do FB and LinkedIn work on your end?

Ok this drifts completely into off-topic. fb and linkedin are known "bad sites" Please use the support groups like mozillazine for further discussion where this already has been discussed. The orginal Ventura bug is fixed and 2.53.15b1 will contain the fixes. We decided to reschedule and delayed the 2.53.15b1 release. The official beta build is now redone and should appear soon. Till then you need the 2.5316b1 prerelease. We will keep them profile compatible till the 2.53.15b1 release so that up and downgrades are painless.

Restrict Comments: true

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/fba739dbc81c
Get accurate system version info on all macOS builds. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 23 days ago
Resolution: --- → FIXED

https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/95b57b0c5194cee6526c9ab783ecac4ee12e9a6d
Get accurate system version info on all macOS builds. r=IanN a=IanN

Temporary patch for our release branch:
https://gitlab.com/seamonkey-project/seamonkey-2.53-mozilla/-/commit/b057ccd905fa0eb9896b85e9bdec644915fbb665
Fix compiling with SDK >= 10.14. r=IanN a=IanN

Thanks to Brian here.

2.53.15b1 will appear soon. If the prerelease works for you you can stay on it till the final 2.53.15 appears or stay current here and test future stuff.

Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.