Closed Bug 1797703 Opened 3 months ago Closed 3 months ago

fixed positioned elements are broken on several websites

Categories

(Core :: Layout, defect, P1)

defect

Tracking

()

VERIFIED FIXED
108 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- unaffected
firefox108 + verified
firefox109 --- verified

People

(Reporter: soeren.hentzschel, Assigned: TYLin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files, 1 obsolete file)

[Tracking Requested - why for this release]:

Fixed positioned elements are broken on several websites. To give you two examples:

Example 1:

  1. Open https://www.grossarlerhof.at/de/wohnen/angebote/auszeit-vom-alltag-4-3-so-do-~p95
  2. Press the large button to accept cookies
  3. Scroll down and up

Expected:

A bar with icons and buttons is fixed to the bottom of the window.

Actual:

The bar is not fixed to the bottom. Instead it's shown on the wrong position. (Sometimes it works, so maybe you have to reload a few times to reproduce the issue).

Example 2:

  1. Open https://forum.netcup.de/ (it uses a popular forum software so potentially many websites are affected)
  2. Scroll a bit down
  3. Press the top link "Anmelden oder registrieren"

Expected:

Fully visible dialog and the background mask is above the whole window.

Actual:

The dialog is truncated at top and the background mask does not cover the whole window.

Flags: needinfo?(aethanyc)
Attached image broken example 1
Attached image broken example 2
Severity: -- → S2
Priority: -- → P1

Tree Style Tab's pinned tab do not display correctly for 2nd+ pinned tabs.

STR:

  1. Install Tree Style Tab.
  2. Pinned 2 or more tabs.
  3. Press F1 to close and reopen Tree Style Tab tab bar.

This is regressed by bug 1797011 so maybe it is the same issue as comment 0.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Duplicate of this bug: 1797813

Emilio has a patch to fix this bug.

Flags: needinfo?(aethanyc)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4dfea46f3cd0
Fix frame constructor save state restoration. r=TYLin,layout-reviewers
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/36698 for changes under testing/web-platform/tests
Upstream PR was closed without merging
Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ce77511413a
Fix frame constructor save state restoration. r=emilio
Attachment #9300588 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
Upstream PR merged by moz-wptsync-bot
Duplicate of this bug: 1798061
Duplicate of this bug: 1798077
Assignee: emilio → aethanyc
Blocks: 1797995
Flags: qe-verify+

Reproducible on a 2022-10-27 Nightly build on macOS 12 using the STR from Comment 0 and Comment 4. Confirming that all 3 issues are fixed on Firefox 108.0b2(build ID: 20221115200658) and Nightly 109.0a1(build ID: 20221116182402) on macOS 12, Windows 10, Ubuntu 22.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.