Closed Bug 1799106 Opened 3 months ago Closed 19 days ago

Gmail emails not fetched into central inbox (deferred inbox) with "Get Messages" button

Categories

(MailNews Core :: Networking: POP, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102+ affected, thunderbird109 affected)

RESOLVED FIXED
110 Branch
Tracking Status
thunderbird_esr102 + affected
thunderbird109 --- affected

People

(Reporter: tomasz_smykowski, Assigned: rnons)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/107.0.0.0 Safari/537.36

Steps to reproduce:

  1. Have a "Local folders" account
  2. Set up e-mails from multiple providers to be stored in one Inbox of "Local folders" Inbox
  3. Add Gmail account
    Method: POP3
    Set it to be included in fetching emails with "Get Messages"
    Adding the account works on default settings
  4. Click on the Inbox of the newly created account
  5. Click "Get Messages"
  6. It fetches the messages
  7. Switch the account to store messages in "Local folders" Inbox and include it in "Get Messages"
  8. Click "Local folders" Inbox.
  9. Click "Get Messages"

Actual results:

Thunderbird fetches emails from other providers, but ignores Gmail accounts

Expected results:

Emails from Gmail account are fetched

Summary: Gmail emails not fetched into central inbox with "Get Messages" button → Gmail emails not fetched into central inbox (deferred inbox) with "Get Messages" button

Seems to work for me. Is there anything in the Error Console? If you set mailnews.pop3.loglevel to All, do you see anything like

mailnews.pop3.3: Connecting to pop://pop.gmail.com:995  
mailnews.pop3.3: Connected 
mailnews.pop3.3: S: +OK Gpop ready for requests

@Ping Chen

I have:

  • set mailnews.pop3.loglevel to All
  • opened the console with CTRL+SHIFT+J
  • clicked "Get messages"

Results:

  • There are no errors
  • In the debug section there is nothing with "pop.gmail.com"

(In reply to Tom from comment #2)

  • There are no errors
  • In the debug section there is nothing with "pop.gmail.com"

Nothing at all in the error console?

Flags: needinfo?(tomasz_smykowski)

I think go back to the beginning here.

Try pressing Shift+F5 instead of clicking get messages. Does it work now?

Misunderstandings about get message and the fact it only gets messages for the currently selected account, and the need is to actually get all new messages from all accounts (shift+F5) which is on the drop-down part of get messages are almost as old as Thunderbird. So let's see if this is another of them.

Thank you all for the support. Matt, you are right, there is an item called "Get All New Messages" in the dropdown.
Before that I had all accounts set up to one inbox folder. So it is why it confused me.

Is there a way to change "Get Messages" button to "Get All New Messages"?
It would be lovely, because it seems like it should be the default

Flags: needinfo?(tomasz_smykowski)

Update: I was testing for some days now the "Get All New Messages" button, and it occurs it does not download messages from the Gmail account.
To fetch e-mails from Gmail account I have to specifically fetch messages for that account.

So this bug report is still valid

Attached image error.png

I have the same problem but it seems I know the rootcause of it. I have TB in different language than english (CZ). In the "Extended" account there is a checkbox enabling affected account to be added to download queue. It's not checked, when I check it and hit OK following messages appears in the error console see attached screenshot. I checked the mentionec code and there is

// Check if we are deferred to the local folders, and create INBOX if needed.
let server = MailServices.accounts.getAccount(accountKey).incomingServer;
if (server instanceof Ci.nsILocalMailIncomingServer) {
  if (!server.rootFolder.containsChildNamed("Inbox")) {
    server.rootFolder.createSubfolder("Inbox", null);
  }
}

So it seems for some reason it pass checking the Inbox folder, then tries to create it and fails (because there is such a folder). As I mentioned above - name of Inbox folder is in local language (CZ)! So there is no explicit "Inbox" folder but local name.

See Also: → 1777276
Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

The patch should fix comment 8, but not sure about comment 0. Also due to bug 1766080, I can't generate a local l10n build to test the patch right now.

Component: Untriaged → Networking: POP
Product: Thunderbird → MailNews Core
Target Milestone: --- → 110 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/fdebd932734c
Fix creating Inbox for deferred server in l10n build. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 19 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.