Last Comment Bug 179956 - Parser and editor should agree on blockness of captions
: Parser and editor should agree on blockness of captions
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Editor (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla17
Assigned To: :Ms2ger
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-13 10:57 PST by Bernd
Modified: 2012-08-09 04:10 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (950 bytes, patch)
2012-08-06 00:41 PDT, :Ms2ger
ehsan: review+
Details | Diff | Review

Description Bernd 2002-11-13 10:57:35 PST
when I start the composer in a debug build,
insert a table and then create a caption I see a bunch of assertions like:

###!!! ASSERTION: Parser and editor disagree on blockness: caption: '*aIsBlock',
 file c:/moz_sour/mozilla/mozilla/editor/libeditor/html/nsHTMLEditor.cpp, line 5
75

It would be cool, if you could fix this because this popups make it quite
difficult to investigate bug 105467
Comment 1 Joe Francis 2003-01-19 18:08:34 PST
I'm either going to fix this or turn off the warning.
Comment 2 :Ms2ger 2012-08-06 00:41:12 PDT
Created attachment 649203 [details] [diff] [review]
Patch v1

Given that Joe hasn't fixed it in the last decade...
Comment 3 :Ms2ger 2012-08-09 04:10:02 PDT
Didn't make M1, I'm afraid.

https://hg.mozilla.org/mozilla-central/rev/b0b9d41f016a

Note You need to log in before you can comment on or make changes to this bug.