Closed Bug 1799934 Opened 3 months ago Closed 2 months ago

Improve the UI style of the minimonth date grid

Categories

(Calendar :: Calendar Frontend, enhancement)

enhancement

Tracking

(thunderbird_esr102 wontfix)

RESOLVED FIXED
110 Branch
Tracking Status
thunderbird_esr102 --- wontfix

People

(Reporter: aleca, Assigned: elizabeth)

References

(Blocks 1 open bug, Regressed 2 open bugs)

Details

Attachments

(1 file)

  • Update the UI of the date grid of the mini-month calendar.
  • Defer the header area (navigation buttons) to another bug.
  • Ensure light, dark, and HC mode variations.
  • Ensure the mini-month follows the density variations.
  • Ensure the mini-month looks consistent everywhere it's used (calendar siderbar, event creation dialog, today pane, etc).

The calendar currently uses a special [systemcolors] attribute for a11y purpose.
This was an old implementation from a time we didn't support the prefer-contrast media query.
We can drop this from the CSS of the minimonth.

Status: NEW → ASSIGNED
See Also: → 1804488
  • Update styling of minimonth calendar
  • Make day of week headings bold
  • Change color of dates outside of current month
  • Style selected date
  • Add density padding variables
  • Style days with events
Attachment #9307439 - Attachment is obsolete: true
Attachment #9307439 - Attachment is obsolete: false
Attachment #9307439 - Attachment description: WIP: - Bug 1799934: Improve styling of minimonth date grid. r=aleca → Bug 1799934: Improve styling of minimonth date grid. r=aleca
Depends on: 1805463

There's an outstanding patch that has been code reviewed and approved. But I need to fix high contrast in order to not introduce a new bug.

Attachment #9307439 - Attachment description: Bug 1799934: Improve styling of minimonth date grid. r=aleca → WIP: Bug 1799934 - Improve styling of minimonth date grid. r=aleca
Blocks: 1805520
Attachment #9307439 - Attachment description: WIP: Bug 1799934 - Improve styling of minimonth date grid. r=aleca → Bug 1799934 - Improve styling of minimonth date grid. r=aleca
Duplicate of this bug: 1805463
Target Milestone: --- → 110 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/bc43854c8f4c
Improve styling of minimonth date grid. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
No longer depends on: 1805463
Regressions: 1805767
See Also: → 1805763
Regressions: 1808643
You need to log in before you can comment on or make changes to this bug.