Closed Bug 1801035 Opened 2 years ago Closed 2 years ago

The download window should have a smaller minimum resizable width/height/size

Categories

(Firefox :: Downloads Panel, defect, P2)

Firefox 107
Desktop
All
defect

Tracking

()

VERIFIED FIXED
109 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- wontfix
firefox108 --- wontfix
firefox109 --- verified

People

(Reporter: davekeyes, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Firefox_Downloads.jpg

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

Click on the hamburger menu icon, select Downloads. The window popup huge, needs the sizing ability to be added back to the window.

Actual results:

Cannot resize the Downloads window.

Expected results:

Ability to resize the window.

Hi,

I'm able to resize the window just fine using Firefox 107 or Firefox Nightly 109.0a1 on Windows 10 and MacOS 11.

Could you check if this also occurs to you in troubleshooting mode? Here is a link to help you with that:
https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode#w_how-to-start-firefox-in-troubleshoot-mode

Thanks!

Flags: needinfo?(davekeyes)

I tried it in the troubleshooting mode, still the same problem. I am running the Firefox 107 version. When I move my mouse pointer over the edge or corners, the mouse point does change like you would expect it to when sizing a window. But nothing happens when I click the left mouse button and move my mouse pointer. I can resize the firefox browser just fine, not the Download window. Are you able to resize the download window?

Flags: needinfo?(davekeyes)
Component: Untriaged → Downloads Panel

I checked some more on the bug I reported. I can size the download window larger, not smaller, which I need to do. The default window size is too large. I was able to do this prior to this version. Maybe I can go back and reload the previous version of firefox.

(In reply to davekeyes@davidkeyes.com from comment #4)

I checked some more on the bug I reported. I can size the download window larger, not smaller, which I need to do. The default window size is too large. I was able to do this prior to this version. Maybe I can go back and reload the previous version of firefox. I installed a previous version from 107 to 106.0b9 and I am able to decrease the size of the Download window, hooray!!! I turned off the automatic download of all new versions, until you can fix this problem.

Based on mozregression and bug 1792809 comment 18, it seems pretty clear that this was regressed in bug 1792809.

I'm not sure what we could do to fix this given the min-width is used as the default size as well - I don't know how hard it'd be to split those. Emilio?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(emilio)
OS: Unspecified → All
Regressed by: 1792809
Hardware: Unspecified → Desktop
Summary: The download window needs the sizing attribute added back. → The download window should have a smaller minimum resizable width

if we are going to reduce the min-width as consequence, please consider we're evaluating to move back labels to the side of fields in the Library (and only there) for other reasons, thus I'd not go further than a 10em reduction.

Severity: -- → S3
Priority: -- → P2
Summary: The download window should have a smaller minimum resizable width → The download window should have a smaller minimum resizable width/height/size

We can set a smaller min-width, but set the width / height attributes to determine the initial window size. Would that not work for any reason?

Flags: needinfo?(emilio)

(In reply to Emilio Cobos Álvarez (:emilio) from comment #8)

We can set a smaller min-width, but set the width / height attributes to determine the initial window size. Would that not work for any reason?

No, that sounds fine to me.

I have my download window size as 734 x 540, which is a good size for me.

Flags: needinfo?(emilio)

Emilio, you need info from me? If so, what kind of info?

(No, I marked it as needing information from me, as a reminder to get back to this)

Assignee: nobody → emilio
Flags: needinfo?(emilio)

According to Transvision, this is barely localized (only two locales set
a non-default width, and they all do it to just slightly more than
usual).

So standardize the initial size on that (800x500), remove the
localization, and remove the minimum size constraint, which wasn't there
before the regressing bug.

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58d76353a6c2
Stop localizing places initial window size. r=Gijs,fluent-reviewers
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
Flags: qe-verify+

Verified fixed on Firefox Nightly 109.0a1 (20221201161829)

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Thank you for fixing this, I just got the 109.0b2 version and quickly checked out the download window. I have been using the nightly version of Firefox, but now switched back to the general released one. As far as I am concerned this bug has been squashed and you can close it.

Duplicate of this bug: 1806602
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: