Closed Bug 1792809 Opened 2 years ago Closed 2 years ago

Content area of Library doesn't fill the window

Categories

(Core :: XUL, defect)

Firefox 107
Desktop
All
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox105 --- unaffected
firefox106 --- unaffected
firefox107 --- verified

People

(Reporter: tgnff242, Assigned: emilio)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Attached image Library_Bug.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

  1. Open the Library.
  2. Maximise the window.

Actual results:

The content area of the Library stays at the default size. See screenshot.

Expected results:

This is a regression from Bug 1665476.

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bb9421c2629c9d33c85ba257ad70507ef82aab89&tochange=37180b0bf14ad69cb4e0d952f2c88b26a5e99175

Regressed by: 1665476

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

:emilio, since you are the author of the regressor, bug 1665476, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

I can also reproduce this on Windows10.

Component: Widget: Gtk → XUL
OS: Unspecified → All
Hardware: Unspecified → Desktop
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → emilio
Status: NEW → ASSIGNED
Flags: needinfo?(emilio)
Attachment #9296659 - Attachment description: Bug 1792809 - Make library keep stretching after bug 1665476. r=Gijs → Bug 1792809 - Make library and other windows keep stretching after bug 1665476. r=Gijs

FYI, you probably need similar changes to thunderbird.

Flags: needinfo?(geoff)
I am experiencing this issue -

I hope the troubleshooting info (provided above) is useful in narrowing this down to a specfic revision or patch.

Thanks Emilio, looks like Richard is on the case. I'll CC him here anyway.

Flags: needinfo?(geoff)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0d08050f3ec2
Make library and other windows keep stretching after bug 1665476. r=eemeli
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
Status: RESOLVED → VERIFIED
Flags: qe-verify+

Reproduced the issue with Firefox 107.0a1 (2022-09-29) using the steps from the description, on macOS 12. After maximise the "Library" window, content area stays unchanged, at its initial size.
The issue is verified fixed with Firefox 108.0a1 (20221020215126) on Windows 10x64, macOS 12, and Ubuntu 20.04. The window is correctly maximised along with the content area.

Changing width and height to min-width and min-height (in places.ftl) is causing complaints on SUMO among users who like to have a small Library window admidst various larger windows (for example, showing just the latest download):

We can mention userChrome.css as a workaround, but this is difficult for many users to implement. Were these changes essential or could those minimums be reduced (while also setting the initial width and height to the classic values)?

Regressions: 1801035
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: