[spam] initial size of junk mail controls dialog is huge

VERIFIED FIXED in mozilla1.4beta

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug, {fixed1.5})

Trunk
mozilla1.4beta
fixed1.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

[spam] initial size of junk mail controls dialog is huge

this might be fixed by neils patch at 
http://bugzilla.mozilla.org/attachment.cgi?id=105964&action=edit
Blocks: 11035

Updated

15 years ago
QA Contact: olgam → laurel

Updated

15 years ago
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Hardware: PC → All

Comment 1

15 years ago
Created attachment 106869 [details] [diff] [review]
patch v2

Updated version of Neil's patch.  Two changes: 

* fix a syntax error and also add a forgotten ; in junkMail.xul
* remove a function which is no longer necessary from junkMail.js

Comment 2

15 years ago
Comment on attachment 106869 [details] [diff] [review]
patch v2

r=dmose
Attachment #106869 - Flags: review+
Comment on attachment 106869 [details] [diff] [review]
patch v2

sr=sspitzer

assuming we don't have the "blank on second time problem"

thanks to neil for the patch, and thanks to dmose for testing, cleaning up, and
landing.
Attachment #106869 - Flags: superreview+

Comment 4

15 years ago
Fix checked in; thanks for the patch, Neil!
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 5

15 years ago
*** Bug 181267 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
OK using nov22 commercial trunk: win98, mac OS 10.2, linux rh8
Status: RESOLVED → VERIFIED

Comment 7

15 years ago
I just upgraded to win32 WinME build 2002112208, and the junk mail controls
window is huge.  I resized it, closed the window, and reopened it, and it's huge
again.  I don't see the fixed part...

Comment 8

15 years ago
Yes, confirmed this is back in 12-02 commercial trunk build: win2000.
I don't however, have the same problem on Mac OS 10.2 or win98, both with new
profiles and mac was freshly installed on the machine (wiped out old registry
and such). Didn't try linux yet.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 9

15 years ago
Neil: this is back for me too.  Any ideas what could be going on here?

Comment 10

15 years ago
I can still reproduce this on trunk 2003010908 Win32 Millenium.
taking, but neil, if you have cycles to investigate, that would be great.
Assignee: dmose → sspitzer
Status: REOPENED → NEW

Comment 12

15 years ago
>   -        persist="screenX screenY width height">

Why was this removed?
At least after the window is nicer sized by the user that new size/shape would
stay the same.
(Related: bug 145941 - although I understand that junk mail controls is now a
dialog and not a window. Maybe that makes a difference... (?))

Comment 13

15 years ago
This is fixed for me - 2003031208
Created attachment 118470 [details]
screen shot, from bryner:  "This takes up the entire width of my screen (1152 pixels). "
I don't see this on win32, but bryner is seeing it on linux.
Status: NEW → ASSIGNED
esther, do you see this on linux?
Keywords: nsbeta1
QA Contact: laurel → esther
Target Milestone: --- → mozilla1.4beta

Comment 17

15 years ago
Well, I'm not esther, but I can tell that I do not see this with 2003032505 on
Linux (KDE, SuSE 8.1) anymore. 
Just created a new profile and tested and so on...
(I also do not see this on Win2k anymore - and yes, I'm sure some weeks ago I
still saw it.)

Comment 18

15 years ago
Mail triage team: need info.  Esther to check if this is still an issue.
Whiteboard: [need info]

Comment 19

15 years ago
I can't reproduce this on my linux system with build 20030326.  Red Hat 7.2 

Comment 20

15 years ago
I can't reproduce this on winxp with build 20030326. New profile .

Comment 21

15 years ago
Mail triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Whiteboard: [need info]

Comment 22

14 years ago
Created attachment 131043 [details] [diff] [review]
new patch v1

I don't know why, but it works for me (WinXP, Mozilla/5.0 (Windows; U; Windows
NT 5.1; en-US; rv:1.5b) Gecko/20030901).

Updated

14 years ago
Attachment #131043 - Flags: superreview?(sspitzer)
Attachment #131043 - Flags: review?(dmose)

Comment 23

14 years ago
Comment on attachment 131043 [details] [diff] [review]
new patch v1

Actually you could probably completely remove the id.

Comment 24

14 years ago
Created attachment 131148 [details] [diff] [review]
new patch v2

Remove the ID completely.
Attachment #131043 - Attachment is obsolete: true

Updated

14 years ago
Attachment #131148 - Flags: superreview?(sspitzer)
Attachment #131148 - Flags: review?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #131043 - Flags: superreview?(sspitzer)
Attachment #131043 - Flags: review?(dmose)

Updated

14 years ago
Attachment #131148 - Flags: review?(neil.parkwaycc.co.uk) → review+

Comment 25

14 years ago
Comment on attachment 131148 [details] [diff] [review]
new patch v2

sr=bienvenu
Attachment #131148 - Flags: superreview?(sspitzer) → superreview?(bienvenu)

Updated

14 years ago
Attachment #131148 - Flags: superreview?(bienvenu) → superreview+

Comment 26

14 years ago
Comment on attachment 131148 [details] [diff] [review]
new patch v2

This is a very small but useful change with very low risk, so I'm asking for
approval.
Attachment #131148 - Flags: approval1.5?

Comment 27

14 years ago
Fix checked in to the trunk, leaving open for possible branch fix.

Comment 28

14 years ago
*** Bug 214931 has been marked as a duplicate of this bug. ***

Comment 29

14 years ago
Why was the feature to save the size and position of the Junk Mail Controls
window removed? (See also comment #12)

Comment 30

14 years ago
I don't know why, but the Search Messages window also doesn't have it.

Comment 31

14 years ago
Originally the dialog appeared with the width of your screen, which was a bit of
a bug. It was then fixed to a proper width, and made nonresizable, but that
affected people who had already used it. So that was fixed too. If you want to
be able to save its position then IMHO that's a separate request.

Comment 32

14 years ago
Neil: The Junk Mail Controls dialog is still resizable in build 20030912. So I
think it should remember its size and position. I filed Bug 219239 about this.

Comment 33

14 years ago
Comment on attachment 131148 [details] [diff] [review]
new patch v2

a=asa (on behalf of drivers) for checkin to the Mozilla 1.5 branch. Please add
the fixed1.5 keyword when this is landed on the branch. Thanks.
Attachment #131148 - Flags: approval1.5? → approval1.5+

Comment 34

14 years ago
Whoops, forgot to mark this fixed on branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago14 years ago
Keywords: fixed1.5
Resolution: --- → FIXED

Comment 35

14 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.