Manual "Run selected filter(s)" doesn't work when multiple filters are selected.

RESOLVED FIXED

Status

MailNews Core
Filters
RESOLVED FIXED
15 years ago
9 years ago

People

(Reporter: Bob Lockie, Assigned: Karsten Düsterloh)

Tracking

({fixed-seamonkey1.1.2, fixed1.8.1.2, verified1.8.1.3})

Trunk
fixed-seamonkey1.1.2, fixed1.8.1.2, verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021112
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021112

When all filters are selected and as folder is selected then filters can not be
manually run.


Reproducible: Always

Steps to Reproduce:
1. Open mail.
2. Select the "Tools/Message Filters" menu.
3. Highlight all filters with shift-click.
4. Select the "Sent" folder from the "Manually run selected filter(s) on
folder:" dropdown list.
5. Select the "Run Now" button.

Actual Results:  
No messages are filtered.

Expected Results:  
All filters should run.
I confirm this bug, occuring when several filters are selected to launch a
manual filtering.

Comment 2

15 years ago
You can use the menu item Tools|Run Filters on Selected Folder to accomplish this.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
'Tools|Run Filters on Selected Folder' works for 'All Filters' but when I 
select only a few filters (and not all) I have the same problem (no messages 
are filtered) and I can't find a workaround for this problem.
mass re-assign.
Assignee: naving → sspitzer

Comment 5

14 years ago
I just tried to replicate this problem with 1.6b and found that, with two 
filters selected, one was run (on the Sent box).  Running each filter 
individually worked.

Comment 6

13 years ago
I'm using 1.7 Beta and have the following issues with Message Filters:

- Running Tools->"Run Filters on Folder" has no effect on any of my folders
- Running Message Filters->Select one filter then "Run Now" has not effect on 
the folder
- Running Message Filters->Select multiple filters then "Run Now" has not 
effect on the folder

However, When mail is uploaded from IMAP the filters are run successfully on 
the InBox.

Comment 7

13 years ago
It isn't neccesssary to select several filters, with Mozilla 1.7.2, the bugs are
what Greg commented in comment #6 (I add the bug number that have been entered
for those problems)

- Running Tools->"Run Filters on Folder" has no effect on any of my folders (bug
#253368)
- Running Message Filters->Select one filter then "Run Now" has not effect on 
the folder (bug #252041)
- Running Message Filters->Select multiple filters then "Run Now" has not 
effect on the folder
- No filtered subfolders (bug #257415)

So, with all these problems with filters and IMAP, has somebody at Mozilla had a
look at them? ;-)

Comment 8

13 years ago
Michael, this problem is not IMAP-specific, and it is in fact about having 
multiple filters selected and "Run now."  Still a problem with POP in 1.7.2, 
I just checked.

Greg Cook, you might look at the bugs Michael referred to in comment 7.
Product: MailNews → Core

Comment 9

13 years ago
Tweaking text in summary to match the dialog.
Summary: "Manually run selected filter(s) on folder:" doesn't work when multiple filters are selected. → Manual "Run selected filter(s)" doesn't work when multiple filters are selected.

Comment 10

11 years ago
This was mistakenly posted to bug 201244. There seem to be other reports relavent to this bug, 180239, posted under bug 201244.


Under XP, Thunderbird 1.5.

By hand, I moved a single email from a Local Folders folder named
"!Spam_Delete" to the filters' account's Inbox.

The first two filters in the rules check whether the header,
"X-tagged-for-folder" is "!Spam" or "!Spam_Delete", respectively. The filters
move the email to the Local Folders folder of that name. Here is a copy of the
top of the msgFilterRules.dat file:

version="8"
logging="no"
name="Spam"
enabled="yes"
type="1"
action="Move to folder"
actionValue="mailbox://nobody@Local%20Folders/%21Spam"
condition="OR (\"X-tagged-for-folder\",is,!Spam)"
name="Spam_Delete"
enabled="yes"
type="1"
action="Move to folder"
actionValue="mailbox://nobody@Local%20Folders/%21Spam_Delete"
condition="OR (\"X-tagged-for-folder\",is,!Spam_Delete)"

The email had the header, "X-tagged-for-folder: !Spam_Delete" and had been
properly routed when it came in (from a POP3 server on localhost).

I selected these first two rules and ran them on the Inbox. Nothing happened.
Then I selected the second rule and ran it. The email was moved to the proper
folder.
(Assignee)

Updated

10 years ago
Duplicate of this bug: 276556
(Assignee)

Comment 12

10 years ago
Created attachment 255714 [details] [diff] [review]
fix index handling

This is so sad. For about 5 years nobody can't even have looked into the code, since the actual bug is just so obvious... :(
Assignee: sspitzer → mnyromyr
Status: NEW → ASSIGNED
Attachment #255714 - Flags: superreview?(bienvenu)
Attachment #255714 - Flags: review?(bienvenu)
(Assignee)

Updated

10 years ago
OS: Linux → Windows ME
Hardware: PC → All
(Assignee)

Updated

10 years ago
OS: Windows ME → All
(Assignee)

Updated

10 years ago
Assignee: mnyromyr → nobody
Status: ASSIGNED → NEW
QA Contact: laurel → filters
(Assignee)

Updated

10 years ago
Assignee: nobody → mnyromyr

Comment 13

10 years ago
Comment on attachment 255714 [details] [diff] [review]
fix index handling

thx, karsten!
Attachment #255714 - Flags: superreview?(bienvenu)
Attachment #255714 - Flags: superreview+
Attachment #255714 - Flags: review?(bienvenu)
Attachment #255714 - Flags: review+
(Assignee)

Updated

10 years ago
Attachment #255714 - Flags: approval-thunderbird2?
(Assignee)

Comment 14

10 years ago
Landed on trunk.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Attachment #255714 - Flags: approval-thunderbird2? → approval-thunderbird2+
(Assignee)

Comment 15

10 years ago
Landed on MOZILLA_1_8_BRANCH.
Keywords: fixed-seamonkey1.1.2, fixed1.8.1.2
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620, tested with 2 of my test accounts and filters 
Keywords: verified1.8.1.3

Comment 17

10 years ago
Tested with 2.0.0.0 (20070326) (rc1) - still does not work.
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.