Impl new interfaces for external spell checkers

RESOLVED INVALID

Status

()

Core
Spelling checker
RESOLVED INVALID
15 years ago
3 years ago

People

(Reporter: rods (gone), Unassigned)

Tracking

(Blocks: 3 bugs)

Trunk
mozilla1.3beta
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 7 obsolete attachments)

(Reporter)

Description

15 years ago
 
Can you explain what this is about?
(Reporter)

Comment 2

15 years ago
I have a new set of interfaces based on David Einsteins work that will enable
external spell checkers to work within  Mozilla. The default spell checker will
still be our SC for Netscape. But David said he would port his MySpell over to
work with Mozilla so then Mozilla will have a spell checker.
Status: NEW → ASSIGNED
Blocks: 56301

Comment 3

15 years ago
oh so what did you need on that.
(Reporter)

Updated

15 years ago
Target Milestone: --- → mozilla1.3alpha
(Reporter)

Comment 4

15 years ago
Created attachment 106523 [details] [diff] [review]
New SpellCheck Interfaces

These are the new interfaces for enabling Mozilla to work with external
spellcheckers
(Reporter)

Comment 5

15 years ago
Created attachment 106525 [details] [diff] [review]
patch (interfaces and new glue code)

Here are the interfaces with what I hope is the correct MPL and the new glue
code for mozilla.
Attachment #106523 - Attachment is obsolete: true
(Reporter)

Updated

15 years ago
Attachment #106525 - Flags: superreview?(kin)
Attachment #106525 - Flags: review?(jfrancis)
(Reporter)

Comment 6

15 years ago
Created attachment 106526 [details]
SpellCheck Diagram

Diagram of the object hierarchy

Comment 7

15 years ago
Is bug 58615 a dup of this one? Bug 56301 comment #234 seems to imply that it is.
(Reporter)

Comment 8

15 years ago
*** Bug 58615 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Is this relevant to bug 86886?

Updated

15 years ago
Blocks: 67208, 69687, 119232
(Reporter)

Comment 10

15 years ago
Greg, what this means is that someone can now provide and impl of the apple
spellcheck to these new interfaces.

Comment 11

15 years ago
Thanks, rods. Sounds like this should be All/All.
OS: Windows 2000 → All
Hardware: PC → All
(Reporter)

Comment 12

15 years ago
Comment on attachment 106525 [details] [diff] [review]
patch (interfaces and new glue code)

The interfaces are fine, I am obsoleting this because I have made some
significant changes to some of the glue code and I don't want this patch to be
reviewed. Plus, I think I will be moving this to the "extensions" directory.
Attachment #106525 - Attachment is obsolete: true

Updated

15 years ago
Attachment #106525 - Flags: superreview?(kin)
Attachment #106525 - Flags: review?(jfrancis)
(Reporter)

Comment 13

15 years ago
Created attachment 109251 [details] [diff] [review]
new spellcheck directory in extensions
(Reporter)

Comment 14

15 years ago
Created attachment 109252 [details] [diff] [review]
Changes to editor directory
(Reporter)

Comment 15

15 years ago
Created attachment 109254 [details] [diff] [review]
debug pref panel changes
(Reporter)

Comment 16

15 years ago
reassigning
Assignee: rods → kin
Status: ASSIGNED → NEW

Updated

15 years ago
Target Milestone: mozilla1.3alpha → mozilla1.3beta
(Reporter)

Comment 17

15 years ago
taking back
Assignee: kin → rods
(Reporter)

Comment 18

15 years ago
Created attachment 110000 [details] [diff] [review]
patch

This patch contains only the changes for splitting the glue code apart and
being able to spellcheck an arbitrary selection
Attachment #109251 - Attachment is obsolete: true
Attachment #109252 - Attachment is obsolete: true
Attachment #109254 - Attachment is obsolete: true

Comment 19

15 years ago
+#ifdef XP_MAC
+#define IS_NBSP_CHAR(c) (((unsigned char)0xca)==(c))
+#else
+#define IS_NBSP_CHAR(c) (((unsigned char)0xa0)==(c))
+#endif

That might need to be 
#if defined(XP_MAC) || defined(XP_MACOSX)
(Reporter)

Comment 20

15 years ago
Created attachment 110025 [details] [diff] [review]
patch for config files

These files will put the mozilla/extensions/spellcheck into the build
(Reporter)

Updated

15 years ago
Attachment #110025 - Flags: superreview?(kin)
Attachment #110025 - Flags: review?(jfrancis)
(Reporter)

Updated

15 years ago
Attachment #110000 - Flags: superreview?(kin)
Attachment #110000 - Flags: review?(jfrancis)
Rod, 

what is the status on this bug? Can we start porting mozdev's spell checker to
the new glue code?

Comment 22

14 years ago
Any chance of this going in during the 1.4 cycle?

Updated

14 years ago
Blocks: 129704

Comment 23

14 years ago
Has the now Mozilla roadmap any influence on this bug? Will 
Minotaur/Thunderbird/Moz1.5 ship with a spellchecker? AFAIK additions/plugins 
should be easier to handle with the new approach. Will the spellchecker remain a 
mozdev addon, or will it once be part of the distribution?

Comment 24

14 years ago
Now that mozdev spellchecker is in the tree, is this bug still relevant?

Updated

13 years ago
Component: Editor: Core → Spelling checker
QA Contact: sujay → core.spelling-checker
Assignee: rods → nobody
I'm pretty sure this is no longer valid.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Attachment #110000 - Attachment is obsolete: true
Attachment #110000 - Flags: superreview?(kinmoz)
Attachment #110000 - Flags: review?(mozeditor)
Attachment #110025 - Attachment is obsolete: true
Attachment #110025 - Flags: superreview?(kinmoz)
Attachment #110025 - Flags: review?(mozeditor)
You need to log in before you can comment on or make changes to this bug.