Interface with Apple's spell checker arch on Mac OS X

NEW
Unassigned

Status

()

Core
Spelling checker
P3
enhancement
17 years ago
4 days ago

People

(Reporter: hsivonen, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 2 bugs)

Trunk
All
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Apple provides a spell checker architecture in Mac OS X. It would be nice if
Mozilla could use that spell check service.

Comment 1

17 years ago
dup of 58615

*** This bug has been marked as a duplicate of 58615 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

17 years ago
What is the architecture under Mac OS X? Is it anything related to the OS Classic Word 
Services architecture I requested in bug 67208?

Comment 4

17 years ago
I don't think this is really a dupe of bug 58615.

Comment 5

17 years ago
Reopening as I suspect this is not exactly the same as bug 58615.

This bug probably depends on 58615. That bug appears to be about opening up the
spelling checking system to outside components, while this one is specifically
about hooking up to Mac OS X's built-in spelling checker Service; an alternative
to bundling yet another spelling checker with an application.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 6

17 years ago
Reassigning to Kin per Beppe for re-evaluation. Kin, please see my Comment #5.

I've also added the URL for the relevant Apple developer documentation.
Assignee: beppe → kin
Status: REOPENED → NEW

Comment 7

17 years ago
...and, since Fizzilla is still Carbon rather than Cocoa, see also
[http://developer.apple.com/techpubs/macosx/Carbon/HumanInterfaceToolbox/MenuManager/appservices/].

Updated

17 years ago
Blocks: 119232

Updated

17 years ago
Priority: -- → P3
Target Milestone: --- → Future

Comment 8

17 years ago
Kin, have you had a chance to evaluate this?

Comment 9

17 years ago
Nope, haven't had a chance.

Comment 12

16 years ago
*** Bug 173452 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: [RFE] Interface with Apple's spell checker arch on Mac OS X → Interface with Apple's spell checker arch on Mac OS X

Comment 13

16 years ago
Making noise... 

Apple Spell is already there for the using, by default, on all OSX
installations. Mozilla should take advantage of this for the email client and
save itself from more memory bloat (at least comparitavely to other platforms)

Comment 14

16 years ago
In NSTextView there is a method, -
(void)setContinuousSpellCheckingEnabled:(BOOL)flag

that should do what you need to do, or take a look at the documentation.  Good
Luck & keep up the good work.

Updated

15 years ago
Assignee: kinmoz → nobody
Component: Editor: Core → Spelling checker
QA Contact: sujay → core.spelling-checker

Updated

15 years ago
Target Milestone: Future → ---

Comment 17

13 years ago
I don't have any code to offer, but the lack of spellcheck is the _only_ reason
Safari is still in my dock!

Comment 18

13 years ago
This is absolutely NOT a duplicate of 58615.  That's "Need to investigate sharing the XP portion of the Netscape 6 spellchecker."  

If that was worked on it wouldn't even touch this one.  Super! It works on XP.  Not on the Mac.  

The Macintosh Operating System has a spell checker built-into it, available to every Carbon application.  

Comment 20

12 years ago
Still using Safari just because of this real deal-breaker.

Comment 21

10 years ago
Process question... How can an issue entered in 2001 still be in the status "New"?

If this isn't going to be addressed, let's mark it WONTFIX.

Comment 22

10 years ago
This was already fixed by bug 151040 (for all apps, not just Camino).

But the osxspell code doesn't allow to switch the dictionary language, and OS X only ships 14 dictionaries or so, but we need a lot more.
So bug 422760 reverted that and made us use hunspell on all platforms and apps except Camino, which still uses osxspell.

Reenabling osxspell requires fixing bug 419959 (allow to switch the dictionaries) and a solution for the missing locales, like third-party OS-level dictionaries, or converting the hunspell dictionaries to OS X dictionaries.

However, the spellcheck code first needs an active, dedicated developer (owner).
Depends on: 151040, 419959

Comment 23

10 years ago
Found this bug and I also think this would be a good improvement. Because the mozilla spell checker in Thunderbird doesn't work very well for me at the moment. I hope there is a solution for the problems mentioned in #22. 
But the url at the top is a way old, I think. Don't know what the original page was, but this seems newer: http://developer.apple.com/documentation/Cocoa/Conceptual/SpellCheck/SpellCheck.html

Updated

10 years ago
Hardware: PowerPC → All

Comment 24

8 years ago
A big plus of the OS X spell checker is that it can guess the used language.  It actually even handles multiple languages in the same text component quite fine.

Updated

8 years ago
Blocks: 606156
For reference, old (Camino-specific?) code to this effect was removed in
https://hg.mozilla.org/mozilla-central/rev/f4af0c314193
What languages does the macOS system spell checker support that Hunspell doesn't, except Finnish? (At least as of El Capitan, the macOS system spell checker support for Finnish is inferior to Voikko [Ubuntu/Debian system spell checker for Finnish] and the Windows 10 system spell checker for Finnish.)

What languages does the macOS system spell checker support better than Hunspell does?

Comment 27

a year ago
It's not about better support or more languages, it's about the lack integration with the OS which makes the product unattractive.

Users get used to a spell checker and want to use the same everywhere. They don't want to re-learn a new interface just for your product.

Users also train and add words to the native spell checker. Absolutely no one wants to start that work again with each new program that decides to bundle its own service that the OS already provides.

If you don't take OS specific integration seriously, your users will not take your product seriously.
Blocks: 1149826
See Also: → bug 422760
See Also: → bug 469499
You need to log in before you can comment on or make changes to this bug.