latest trunk breaks freetype

VERIFIED DUPLICATE of bug 179667

Status

()

Firefox
General
--
major
VERIFIED DUPLICATE of bug 179667
15 years ago
15 years ago

People

(Reporter: Joshua Kwan, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021115 Phoenix/0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021115 Phoenix/0.4

Latest Phoenix trunk has broken Freetype support.
I believe the 11-13 build was the last one with working Freetype -
is this because you are using a different implementation now that I need to install?

Reproducible: Always

Steps to Reproduce:
1. Go to a page.
2. See the non Truetype fonts.



Expected Results:  
Shown the right fonts.

Comment 1

15 years ago
I wonder if this has to do with bug 179667 comment 10.
Reporter, what is your version of Freetype?
(Reporter)

Comment 2

15 years ago
I am using Freetype2 version 2.1.2-10.

apt archives for Debian have not released a 2.1.3 package yet (i read that other
bug you mentioned.) but if they do, i will try it again. I doubt it is that, but
note that I am experiencing that sloping problem as well sometimes...
(Reporter)

Comment 3

15 years ago
Okay, status update.

A little research around my system showed that all my TTF (hence handled by
Freetype) fonts had stopped being recognized with the latest freetype release on
apt. Hence they were all still ACCESSIBLE - X-Chat uses lucida sans unicode and
it still works, but no longer appears in the font choice list.

I would like to keep this bug open once freetype is 'fixed' just in case the
problem occurs again after other apps have started working again.

Comment 4

15 years ago
Joshua, the latest Freetype has the fix, according to bug 179667 comment 11. So,
no reason to keep this one open (moreover, it's not a Mozilla/phoenix bug...).

*** This bug has been marked as a duplicate of 179667 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

15 years ago
Yes.

I am extremely stupid (well, kind of naive too.) I had done some editing through
Debian's dpkg-reconfigure xserver-xfree86 and it had clobbered my self-added
font paths without my knowing. :( Thus removing /usr/share/fonts/truetype from
the FontPath...

Sorry for the inconvenience.

Comment 6

15 years ago
Mass verifying of old bugs.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.