Last Comment Bug 180411 - Plugin Finder Service is not invoked for OBJECT element
: Plugin Finder Service is not invoked for OBJECT element
Status: RESOLVED WONTFIX
[PL2:NA]
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 2000
: P3 normal with 1 vote (vote)
: Future
Assigned To: Peter Lubczynski
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-15 17:42 PST by Arun Ranganathan
Modified: 2014-09-26 19:51 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
HTML4.01 validating page with OBJECT element and no obtention path... (1.50 KB, text/html)
2002-11-15 17:44 PST, Arun Ranganathan
no flags Details
SWF file used in the sample HTML (previous HTML) (1.68 KB, application/x-shockwave-flash)
2002-11-15 17:46 PST, Arun Ranganathan
no flags Details

Description Arun Ranganathan 2002-11-15 17:42:34 PST
Currently, for code like this:

<object id="myFlash" data="javascript_to_flash.swf"
type="application/x-shockwave-flash" width="366" height="142">
    	<param name="movie" value="javascript_to_flash.swf">
    	<param name="quality" value=high>
    	<param name="swliveconnect" value="true">    	
</object>

the PFS (Plugin Finder Service) is not invoked.  In bug 134445 we saw to it that
the 'codebase' attribute plays the same role as the 'pluginurl' attribute in the
old 'embed' element.  
But in the old 'embed' element, if you never specified a pluginurl, the PFS
would be invoked.  That's not the case for the object element.

Expected Behaviour: NOT specifying an obtention path should invoke the PFS as in
the case of the embed element.

Actual Behavior: This is not the case.
Comment 1 Arun Ranganathan 2002-11-15 17:44:50 PST
Created attachment 106448 [details]
HTML4.01 validating page with OBJECT element and no obtention path...

The HTML page makes use of an SWF file that I am also attaching so that you can
put the two together and use them in a single directory.
Comment 2 Arun Ranganathan 2002-11-15 17:46:48 PST
Created attachment 106450 [details]
SWF file used in the sample HTML (previous HTML)

This is an SWF file of MIME type application/x-shockwave-flash
Comment 3 rubydoo123 2002-11-15 22:19:08 PST
we will need to construct a mechanism if the media type is missing and trigger
off the data type, at least for now. As the XHTML specs come into play, this may
be against the spec requirements.
Comment 4 Arun Ranganathan 2002-11-18 03:56:55 PST
I'm proposing that if the object is missing, at LEAST display the missing jigsaw
puzzle piece.  Then the user can click on it and search the PFS for it. 
Currently, if the object is missing, we display nothing.
It would be truly unfortunate if doing this minimal feature violated a spec.,
because then the object tag's functionality would be a bit under par compared to
embed tag, which at least displays the missing jigsaw piece.
Comment 5 Arun Ranganathan 2002-11-18 04:08:34 PST
Further: if there are nested object tags, keep going till you find one you can
display (as the HTML 401 spec. suggests).  But if you can display none, display
the missing jigsaw piece for the outermost element.  In the case of a solitary
object element, if it is missing, display the missing puzzle piece just as we do
for solitary embed elements.
Comment 6 rubydoo123 2002-11-20 09:30:54 PST
We discussed this particular functionality request at the W3C HTML Working Group
meeting this morning. Per the discussion, this feature would be in direct
opposition of the standard. It is the responsibility of the author to include
alternate text, the author may have indeed meant to not process/render anything
if the object cound not be found. The user agent SHOULD NOT provide additional
information if the object could nto be processed and the author did not supply
alternative text.
Comment 7 rubydoo123 2002-11-22 10:58:19 PST
To promote a positive user experience and to be consistent within the
application, we will follow the img model. In quirks mode we will display the
puzzle piece and in standards mode (usage of appropriate doctype) we will
suppress the puzzle piece.

The current state is to display nothing.
Comment 8 rubydoo123 2002-11-22 13:20:48 PST
let me finish that comment: if teh inner most object does not contain any nested
information, i.e %block or %inline, then the puzzle piece should be rendered.
Comment 9 rubydoo123 2002-12-03 16:01:05 PST
reassigning to Anthony
Comment 10 rubydoo123 2002-12-12 15:25:47 PST
peterl
Comment 11 Kevin McCluskey (gone) 2003-01-23 17:12:57 PST
nsbeta1-. Peter is overloaded with higher priority issues.
Comment 12 Frank Wein [:mcsmurf] 2005-03-30 10:39:03 PST
BTW: This is also true for the Firefox PFS replacement content.
Comment 13 Justin Dolske [:Dolske] 2014-09-26 19:51:31 PDT
Bug 836415 has now removed the Plugin Finder Service (PFS) from Firefox. As a result, I'm closing all the remaining PFS bugs.

If you're getting this bugmail for an ancient PFS bug, the basic summary of the world today is:

* NPAPI plugins are a dying technology
* PFS was already restricted to assisting with only the 4 most common plugins
* Sites commonly provide their own UI for install a required plugin
* Mozilla is generally focusing on  improving the web platform so that proprietary plugins are not required.

(Note that "plugins" are a completely separate from "browser extensions", such at those found on addons.mozilla.org. The latter are not going anywhere, and are not impacted by the removal of PFS.)

Note You need to log in before you can comment on or make changes to this bug.