Closed Bug 180447 Opened 18 years ago Closed 18 years ago

Browser will say "connecting to ..." then "transferring data from ..." and finally "Done" in the status bar, but site doesnt open (disk cache set to 0 - zero)

Categories

(Core :: Networking: Cache, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 184304

People

(Reporter: frozen-solid-7, Assigned: gordon)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021113

When trying to view certain websites, http://www.bestbuy.com and
http://www.nintendo.com for example, the browser will show that it is working in
the status bar by saying "Connecting to ..." and "Transfering data from ..." and
finally displays "Done" but nothing has changed in the browser window.  If I
open the website directly into a new browser window, it will do the same thing
but only show a blank white page.  However, certain parts of the sites will
open, such as http://www.nintendo.com/camp or http://www.nintendo.com/media
(media requires a password).  I have heard of these sites working for others,
but have never worked for me since I started using Mozilla with version 1.0. I
have tried this on both of my computers (one is a 233 pentium MMX and the other
is a 2ghz laptop) and neither work.  I have tried using many versions since 1.0
and am currently on one of the nightly builds, which seems to work really well
accept for this one problem.  I CAN visit the sites using IE 6.0, just not in
Mozilla.  Using IE seems to be the only real work-around for me.

Reproducible: Always

Steps to Reproduce:
1. Open Browser
2. Direct Browser to http://www.nintendo.com or http://www.bestbuy.com
3. Pay attention to status bar

Actual Results:  
If another page is currently displayed:
Just shows in the status bar as if it's working, then just stops with seemingly
no changes

If opening directly into a new browser:
Just shows in the status bar as if it's working, then just stops and displays a
blank white page.

Expected Results:  
Opened the pages like normal.
WFM, current CVS, linux. Are you using some kind of proxy?
nope, not using any proxies of any kind
If you create a new profile (with mozilla profilemanager) and run moz under that: 
Are the pages still blank?
Yes, I created a new profile and it works now.  Odd...
btw, why would the default profile not work?  what is different about them?

Thanks for all your help, it seems all the pages i've never been able to access
work like a charm now.  Gotta love mozilla ;D
marking worksforme per comment 4
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → WORKSFORME
The bug reappeared for me today, and upon doing some testing I am pretty sure
that I've narrowed down where the bug is.  Just yesterday I changed the memory
cache options to 0 instead of 4096 because a few images weren't wanting to
refresh when I uploaded a newer version of them and was getting sick of clearing
the cache every upload for it to work.  I had done this on my old profile also
but forgot about it when I set up the new profile.  When I went to the site
today and it didn't work I realized that I had changed that option since the
last time I visited the site, and thought mabye that was the error.  I set the
memory cache back to 4069 and hit OK, then closed the browser to restart it
(Mozilla crashed when I was closing it after changing the option back by the
way).  When I reopened Mozilla and tried the site it worked perfectly.  To
double check the bug I set it back to 0 and sure enough bestbuy.com wouldn't
work.  I promptly put it back to 4096 and restarted the browser (once again
Mozilla crashed on exit) and when I reopened everything worked again.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Could be a duplicate of bug 175478 then.
Reporter:
To reload without invoking cache: shift+reload

Hasse is right.. several problems can arise when cache is set to 0. Various bugs
on that over time, bug 125571, bug 136959, bug 175478 are samples..
Summary: Browser will say "connecting to ..." then "transferring data from ..." and finally "Done" in the status bar, but site doesnt open → Browser will say "connecting to ..." then "transferring data from ..." and finally "Done" in the status bar, but site doesnt open (disk cache set to 0 - zero)
networking cache
Assignee: asa → gordon
Component: Browser-General → Networking: Cache
QA Contact: asa → tever
Mozilla1.2.1(Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2.1)
Gecko/20021130) on MacOSX10.2.2 is connecting to and transfering data from
track.ft.com, news.ft.com, and ads.ft.com infinitely (accessing from Japan).

The page appear, and redraws again and again.

Mozilla 1.1 doesn't have such behavior.

per bug 18426, this is dupe of bug 184304

*** This bug has been marked as a duplicate of 184304 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.