If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Events in a remote calendar with UTC START/END dates are not adjusted to local timezone.

RESOLVED DUPLICATE of bug 188095

Status

Calendar
Internal Components
--
major
RESOLVED DUPLICATE of bug 188095
15 years ago
11 years ago

People

(Reporter: Fred, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2b) Gecko/20021016

When subscribing to a remote calendar that uses UTC date format to specify the
starting and ending time of an event, the event appears in the calendar at the
UTC time, not at the time corresponding to the local time zone.

For example, I imported the Toronto Maple Leafs schedule into my calendar and
then published it. This is the published entry:

BEGIN:VCALENDAR
VERSION
 :2.0
PRODID
 :-//Mozilla.org/NONSGML Mozilla Calendar V1.0//EN
METHOD
 :PUBLISH
BEGIN:VEVENT
UID
 :2765F1AA4C-E54C-11D6-86BF-00306566FFA4
SUMMARY
 :Boston Bruins @ Toronto Maple Leafs
CLASS
 :PUBLIC
DTSTART
 :20021120T003000Z
DTEND
 :20021120T033000Z
DTSTAMP
 :20021119T170018
END:VEVENT
END:VCALENDAR

When I subscribe to the calendar containing this event, the event will be
displayed on my remote calendar as starting at 12:00AM Nov. 20, 2002, not 7:00
PM Nov. 19, 2002 (as it really is in my timezone - UTC-500 or EST).

This is not the case for all day events as there is no time involved.

I am using the calendar.xpi as of today (Nov. 19, 2002, I believe the Nov. 12
build?).

Reproducible: Always

Steps to Reproduce:
1. Publish an event.
2. Subscribe to that event you just published
3. Compare the start and end time of the event as it appears in the source
calendar (from which you published it) and the remote calendar.

Actual Results:  
The event is scheduled at a different time. For UTC-X00, it is X hours late in
the calendar.


Expected Results:  
Calender should have noticed the UTC offset and adjusted the start/end times
accordingly to ensure that the event is scheduled correctly.

Comment 1

15 years ago
->Mostafa
Assignee: mikep → mostafah
Status: UNCONFIRMED → NEW
Component: Calendar General → libxpical
Ever confirmed: true
OS: Linux → All

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 188095 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Mass move of libxpical bugs to the Internal Components, per ctalbert.
Component: libxpical → Internal Components
The bugspam monkeys have been set free and are feeding on Calendar :: Internal Components. Be afraid for your sanity!
QA Contact: colint → base
You need to log in before you can comment on or make changes to this bug.