Open Bug 1810165 Opened 1 year ago Updated 2 months ago

SW-WR (layers.acceleration.disabled=true)/Intel&AMD/Win11: Corrupted flickering main window after opening Picture in Picture, minimizing Firefox, resizing PiP

Categories

(Core :: Graphics: WebRender, defect)

Firefox 108
x86_64
Windows 11
defect

Tracking

()

UNCONFIRMED

People

(Reporter: azureb1te, Unassigned, NeedInfo)

References

(Blocks 2 open bugs)

Details

(Keywords: correctness, regression)

Attachments

(2 files)

Steps to reproduce:

  1. Open any video platform such as https://youtube.com
  2. Pop the PiP windows out and minimize Firefox
  3. Resize the PiP window, move it, play with it
  4. UI should now be glitched out, but click the pop-back icon's remains

Actual results:

The entire browser UI glitches out, until a restart

Expected results:

Nothing, the PiP window should've just closed like normal ad the UI remained like before

The Bugbug bot thinks this bug should belong to the 'Toolkit::Video/Audio Controls' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Video/Audio Controls
Product: Firefox → Toolkit

I'd like to provide additional information:

I run an x86 64bit installation of Windows 11 Pro on an Intel Core i5 10500 CPU and an AMD Radeon R5 200 Series GPU
The bug apeared in release 105 as of my findings, 104 works for me without bugging out.

Moving this issue to the Picture-in-Picture component. Buggy behaviour occurs after opening a new Picture-in-Picture window.

Component: Video/Audio Controls → Picture-in-Picture

On second thought, perhaps this would be more appropriate under Graphics considering that this is a rendering issue.

Component: Picture-in-Picture → Graphics
Product: Toolkit → Core
OS: Unspecified → Windows 11
Hardware: Unspecified → x86_64
Summary: Picture In Picture Breaks Firefox → Intel&AMD/Win11: Corrupted flickering main window after opening Picture in Picture, minimizing Firefox, resizing PiP

(In reply to azureb1te from comment #0)
Thanks for the report! Please try to find a regression range (if possible), you will get a pushlog url at the end:
https://www.youtube.com/watch?v=IwrWot3jVFI
https://github.com/mozilla/mozregression/releases/download/5.2.1/mozregression-gui.exe
(links are from https://mozilla.github.io/mozregression/)

I agree that this seems like a Graphics issue, noting that I'm not an expert on graphics.

Hey azureb1te, could you upload the contents of the page when you open the about:support URL? In additional to Darkspirit's very good suggestion to find the regression range, should have some even more helpful.

Severity: -- → S2
See Also: → 1638709

azureb1te, can you attach about:support to this bug? Thank you.

Flags: needinfo?(azureb1te)

I'm sorry, I couldn't figure out how to only post the graphics

Flags: needinfo?(azureb1te)
Flags: needinfo?(ahale)

Can I offer anything else?

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=d630d5cd45293175ae68813f7daeba01d78d4cb6&tochange=9f93a246366f29cbf76c350ab1d5e4bca9b8d630

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8c6f1126927ead909b413c26f63e2945c221cd3e&tochange=a948931a259554f0f85c79db8cbf6f5ac2beb08f

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8c6f1126927ead909b413c26f63e2945c221cd3e&tochange=9816094259f4a61b95b8c0ee75bde3eb9a33f70e

So my previous testing might have been incorrect, however the results are different this ime, and I'm confused

Either way, this time I tested with the same video and I did the same thing in most tests. Pop-out the PiP window and increase it's size
Only upwards increases seem to trigger the glitch

I also don't know which pushlog I have to submit, so I sent the three major ones

I am alright with re-doing the testing, please tell me what to do

WebRender (Software) with dual graphics cards. Pretty nasty flickering problem in web content painting (outside the video).

azureb1te, you have a lot of custom prefs set. Could you try to reproduce with a clean profile? Visit about:profiles to create one and launch it.

Flags: needinfo?(azureb1te)
See Also: → 1830769, 1812982
Summary: Intel&AMD/Win11: Corrupted flickering main window after opening Picture in Picture, minimizing Firefox, resizing PiP → SW-WR (layers.acceleration.disabled=true)/Intel&AMD/Win11: Corrupted flickering main window after opening Picture in Picture, minimizing Firefox, resizing PiP

Redirect a needinfo that is pending on an inactive user to the triage owner.
:bhood, since the bug has high severity, could you have a look please?

For more information, please visit BugBot documentation.

Flags: needinfo?(azureb1te) → needinfo?(bhood)

Ashley, can we move this, and if so, what do we need to do?

Flags: needinfo?(bhood)
Component: Graphics → Graphics: WebRender

I have no idea how to reproduce this, I had attempted several times in the past, and tried again just now, but I can't get it to glitch with WebRender in software or hardware modes, on AMD Radeon drivers. However the about:support in comment #9 indicates GPU 1 is AMD Radeon R5 200 Series and GPU 2 is Intel UHD 630 graphics, it's not clear to me whether the display is driven by the AMD Radeon R5 200 or the Intel UHD 630, it's very possible that having that setup is required to manifest this glitch.

However with it being WebRender (Software) it seems like the GPU drivers shouldn't even be involved in any way that could cause incorrect rendering, so I am actually wondering if it is displaying unfinished software rendered images from WebRender, where the images may be rendering before the text and hence the text appears inconsistently depending on where the display scanout is at when it draws each element.

Without any response after comment #13 it's not easy to make any progress here.

Severity: S2 → S3
Flags: needinfo?(ahale)
Flags: needinfo?(ahale)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: