[dogfood] XPCOM/Proxy needs to be threadsafe!!

VERIFIED FIXED in M14

Status

()

Core
XPCOM
P3
normal
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Assignee)

Description

18 years ago
We are not locking down our hashtables.  This needs to be fixed and an total
analysis done on the thread saftey of xpcom/proxy.
(Assignee)

Updated

18 years ago
Summary: XPCOM/Proxy needs to be threadsafe!! → [dogfood] XPCOM/Proxy needs to be threadsafe!!
(Assignee)

Comment 1

18 years ago
marking as dogfood to get attention.  This will bit us soon.  We should fix
this asap.

Updated

18 years ago
Whiteboard: [PDT-]

Comment 2

18 years ago
Without a reproducible testcase, cannot put on PDT+.  Putting on PDT- for now.
But yes, you have our attention :-)
(Assignee)

Updated

18 years ago
Target Milestone: M13
(Assignee)

Comment 3

18 years ago
will never make it for m12.

Updated

18 years ago
Blocks: 21556

Comment 4

18 years ago
*** Bug 22798 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
there is a test case for this bug attached to bug 22798
as well as lots of commentary that i'm too lazy to copy.

Comment 6

18 years ago
oops, i meant bug 21556. The word is that its a dup of this one
but no one has actually marked it as a dup. Its a dependency.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
(Assignee)

Comment 7

18 years ago
Moving out of m13 to m14.

Comment 8

18 years ago
Hmm...I noticed you've moved it out the M14.
While I may be restating the obvious, this bug completely
wastes mozilla on an SMP machine.  Thus I feel this is a very important
bug and the number of votes for it seem to reflect that.  It should be
quite easy to debug (I know, I should do it myself, rather than whine)
on a SMP machine.  Personally I think this is required for beta and/or dogfood.

Updated

18 years ago
Whiteboard: [PDT-]

Comment 9

18 years ago
niles, bug #21556, depending on 18110, is marked PDT+. Clearing Status
Whiteboard.

Updated

18 years ago
Whiteboard: [PDT+]
(Assignee)

Comment 10

18 years ago
*** Bug 21556 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

18 years ago
I believe that xpcom/proxy is now relatively threadsafe.  The stack crawls that 
I saw today on the smp machine are related to a necko bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
ok to mark Verified per dp.
Status: RESOLVED → VERIFIED

Updated

18 years ago
No longer blocks: 21556

Comment 13

18 years ago
Do you know the bug number for the necko issue?  I still seem to be getting
crashes, although they are now MUCH less frequent, so I'd like to follow up on
that one.

Thanx!
(Assignee)

Comment 14

18 years ago
see:

http://bugzilla.mozilla.org/show_bug.cgi?id=24711
You need to log in before you can comment on or make changes to this bug.