edit-multiple.html.tmpl uses &apos which Internet Explorer cannot use (patch included)

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
User Interface
--
trivial
RESOLVED FIXED
15 years ago
5 years ago

People

(Reporter: Thomas Stromberg, Assigned: Christian Reis)

Tracking

unspecified
Bugzilla 2.16
Bug Flags:
approval +

Details

(Whiteboard: [fixed in 2.16.5] [does not affect trunk], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021112 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021112 Chimera/0.6+

In the "Don't change this group restriction" dialog, Bugzilla uses &apos instead
of the classic &#39 code for the apostrophe. This makes it literally print &apos
if you are using Internet Explorer 5.X



Reproducible: Always

Steps to Reproduce:
1. Get bug list
2. Change multiple tickets ..
3. See message
(Reporter)

Comment 1

15 years ago
Created attachment 106909 [details] [diff] [review]
edit-multiple.html.tmpl patch to change from &apos to &#39
Is there a reason we can't just use a normal apostrophe in here instead of
having to make it an entity at all?  It's not inside an attribute or anything...
Comment on attachment 106909 [details] [diff] [review]
edit-multiple.html.tmpl patch to change from &apos to &#39

HTML encoding issue...	Hixie, see comment 2 on this bug.
Attachment #106909 - Flags: review?(ian)
No reason that I can see, at any rate.
Comment on attachment 106909 [details] [diff] [review]
edit-multiple.html.tmpl patch to change from &apos to &#39

ok, per comment 4, denying review.

We probably should get rid of the ', but let's make it an actual
apostrophe (') instead of '.
Attachment #106909 - Flags: review?(ian) → review-
The User Interface component now belongs to Gerv.  Reassigning all UNCONFIRMED
and NEW (but not ASSIGNED) bugs currently owned by Myk (the previous component
owner) to Gerv.
Assignee: myk → gerv
Reassigning back to Myk.  That stuff about Gerv taking over the User Interface
component turned out to be short-lived.  Please pardon our confusion, and I'm
very sorry about the spam.
Assignee: gerv → myk

Comment 8

15 years ago
Per comment #5 above, this needs a patch, changing status from unconfirmed to new.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

15 years ago
Resolving this. 
 
It has been fixed by this: 
 
07/03/2003 14:31 
gerv%gerv.net  
mozilla/ webtools/ bugzilla/ template/ en/ default/ list/ edit-multiple.html.tmpl  
1.12  
30/28   
Bug 13540 - allow key terms, like "Bugzilla" and "bug", to be altered without 
changing all the templates. Patch by jwilmoth@starbucks.com; r=gerv, 
a=justdave.  
 
Diff available at 
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/webtools/bugzilla/template/en/default/list&command=DIFF_FRAMESET&file=edit-multiple.html.tmpl&rev1=1.11&rev2=1.12&root=/cvsroot 
. 
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Depends on: 13540
Target Milestone: --- → Bugzilla 2.18

Comment 10

14 years ago
*** Bug 234011 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Reopening per bug 234011. (we need it only for the 2.16 branch?)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 12

14 years ago
Errr.. well, the duped bug had a patch on it at least.

Comment 13

14 years ago
Sorry about that, can you repost it here? If you're short on time I can do that. :-)

Updated

14 years ago
Hardware: Macintosh → All

Comment 14

14 years ago
Fixed on the tip, we need it for branch only per previous comments.
Target Milestone: Bugzilla 2.18 → Bugzilla 2.16

Updated

14 years ago
Assignee: myk → kiko
Status: REOPENED → NEW
(Assignee)

Comment 15

14 years ago
I'm a bit crushed -- can you move it and get the reviews going? thanks :)
Created attachment 141263 [details] [diff] [review]
Kiko's patch from bug 234011
Attachment #106909 - Attachment is obsolete: true

Updated

14 years ago
Attachment #141263 - Flags: review+

Updated

14 years ago
Flags: approval?
Flags: approval? → approval+
Whiteboard: [wanted for 2.16.5] [does not affect trunk]
Kiko: this one's yours to check in, right? Whenever suits you.

Gerv
(Assignee)

Comment 18

14 years ago
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/edit-multiple.html.tmpl,v
 <--  edit-multiple.html.tmpl
new revision: 1.4.2.3; previous revision: 1.4.2.2

The branch says "Thanks"!
Status: NEW → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: [wanted for 2.16.5] [does not affect trunk] → [fixed in 2.16.5] [does not affect trunk]
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.