[PP]File in use not replaced after install

VERIFIED FIXED in M12

Status

Core Graveyard
Installer: XPInstall Engine
P3
major
VERIFIED FIXED
19 years ago
3 years ago

People

(Reporter: Jimmy Lee, Assigned: Samir Gehani)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: 1999-11-05-08-M11(MAC)

1. From http://jimbob/trigger2.html, click drop-down menu and select
   f_addsubcomp_macsmpltxt
2. Click Trigger case button to install
3. From "Program" directory, open "simpletext_subdir" folder and launch Simple
   Text application
4. From Seamonkey, go to http://jimbob/trigger2.html, click drop-down menu and
   select f_addsubcomp_macsmpltxt_inus
5. Click Trigger case button to install

Install.StartInstall("Functional: f_addsubcomp_macsmpltxt_inus",
"f_addsubcomp_macsmpltxt", "1.0.1.5", 1);
f = Install.GetFolder("Program", "simpletext_subdir");
Install.AddSubcomponent(regName, "1.0.1.5", jarSrc, f, jarSrc, true);

RESULT:
When we attempt to install a file that is in use, the original file gets renamed
to "SimpleText-1".  The new file does not get installed.  The Install.log shows:

---------------------------------------------------------------------------
http://jimbob/jars/f_addsubcomp_macsmpltxt.jar  --  11/05/1999 13:24:54
---------------------------------------------------------------------------

     Functional: f_addsubcomp_macsmpltxt
     -----------------------------------

     Item [1/1]	Installing:
Webbies:moz115:mozilla-mac-M11:simpletext_subdir:SimpleText

     Install completed successfully
     Finished Installation  11/05/1999 13:24:59

---------------------------------------------------------------------------
http://jimbob/jars/f_addsubcomp_macsmpltxt_inus.jar  --  11/05/1999 13:26:21
---------------------------------------------------------------------------

     Functional: f_addsubcomp_macsmpltxt_inus
     ----------------------------------------

     Install **FAILED** with error -201

     Install **FAILED** with error -201
     Finished Installation  11/05/1999 13:26:26

EXPECTED RESULT:
No error message from the Install.log.  Quitting and restarting SimpleText
should reflect the second installation (126K).
(Assignee)

Updated

19 years ago
Assignee: cathleen → sgehani
Target Milestone: M12

Updated

19 years ago
Blocks: 20203
Is this still a problem?
(Reporter)

Comment 2

19 years ago
1999-12-02-13-M12

I'll check this when Bug 19133 is fixed.  Currently, I'm blocked.
Samir, this depends on the project change and #ifndef removal in
xpfe/bootstrap/nsAppRunner.cpp you volunteered for. Need this in M12, should be
simple and not take much time.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

19 years ago
That was checked in over the weekend so marking fixed.

Comment 5

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
(Reporter)

Updated

19 years ago
Depends on: 6410
(Reporter)

Comment 6

19 years ago
This is a dupe of Bug 6410.  This will be verified when 6410 is fixed.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 7

19 years ago
Build 1999-12-14-08-M12(MAC)

Fixed!

Updated

18 years ago
No longer blocks: 20203
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.