mozilla xpcom objects should gracefully handle being created and destroyed w/o being used

VERIFIED DUPLICATE of bug 181491

Status

VERIFIED DUPLICATE of bug 181491
16 years ago
2 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

16 years ago
The concept is that each xpcom object's destructor should tolerate no methods
being called other than whatever happens when createInstance is called (normally
this is just the c++ constructor) before it is destroyed. xpcom has a facility
for an additional method to be called (no params, but it allows for an object to
try to allocate memory, fail, and return an xpcom error which is converted into
a createInstance failure and js exception if the caller is xpconnect).

*** This bug has been marked as a duplicate of 181491 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v (timeless sucks)
Status: RESOLVED → VERIFIED
(Assignee)

Updated

16 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.