Closed Bug 1815543 Opened 2 years ago Closed 1 year ago

Sort the migrators in the new migration wizard in MRU order descending.

Categories

(Firefox :: Migration, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: mconley, Assigned: steven100695)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We cannot order the individual profiles by MRU (most-recently-used) order, but we can organize the browser list like this. We should do that to make it easier for users to select the browser that they're more likely to want to migrate from (and to select by default the one that was most recently used).

Assignee: nobody → steven100695

The easiest way to do this is to update this method here to include the result of calling await migrator.getLastUsedDate() and assigning that to some property here.

Then, add another step here to sort the Array of objects by that property that you added. Something like:

return results.flat().filter(result => result).sort((a, b) => {
  return a.lastModifiedDate - b.lastModifiedDate;
});
No longer blocks: 1801313
Duplicate of this bug: 1815542
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/86941b3c7c5e
Sort the migrators in the new migration wizard in MRU order descending. r=mconley.
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: