Closed Bug 1815953 Opened 1 year ago Closed 1 year ago

Cannot resize contact pane in Edit mode (especially in horizontal/Table layout)

Categories

(Thunderbird :: Address Book, defect)

Thunderbird 102
defect

Tracking

(thunderbird_esr102- unaffected, thunderbird112? fixed)

VERIFIED FIXED
113 Branch
Tracking Status
thunderbird_esr102 - unaffected
thunderbird112 ? fixed

People

(Reporter: thomas8, Assigned: Paenglab)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug, ux-control)

User Story

From duplicate Bug 1799087 Comment 2:

Ah, I found out how to resize that area. You have to not be in edit mode. When just viewing a contact, it can be resized. But when editing (which is when the smaller size hurts much more), the size is fixed. I have to stop editing, change the size, and then start editing again.

There's also a lot of unused space in that area, meaning that to see most of the key contact data takes about half my screen, taking away from the contact list.

Attachments

(1 file)

Contact pane cannot be resized when in Edit mode, which looks like a usability bug.

STR

  • Seen on TB 102.7.1 (64-bit), Win10 (only after Switch to horizontal layout).
  • In Daily 111.0a1 (2023-02-09) (64-bit), vertical layout also affected.
  1. In address book, Switch to horizontal layout (102) or Table layout (Daily).
  2. Drag splitter above contact display pane down to see more of contacts list for choosing the right contact, so contact pane is vertically small.
  3. Happy to have found the right contact, select it and click Edit quickly (or just press Enter)
  4. Realize that your contact pane is way too small for editing, and try to make it bigger (by dragging splitter up to expand it vertically)

Actual result

  • Cannot resize the contact pane in Edit mode (presumably the splitter has been disabled)
  • Need to interrupt editing, save contact, resize pane, then re-edit contact :-/
  • Contact Display mode is more compact, whereas current Edit mode needs much more space for everything, so users may only realize that their contact pane is too small when they are already in Edit mode.

Expected result

  • Should still be able to resize the contact pane in Edit mode (both vertical and horizontal layout)
  • This looks like an everyday scenario where users may want to see more of the contact while editing

Implementation hints

  • I guess/hope that this will just require excluding the respective splitters from being disabled in Edit mode.
Summary: Cannot resize contact pane in Edit mode (especially in Table layout) → Cannot resize contact pane in Edit mode (especially in horizontal/Table layout)
User Story: (updated)
Duplicate of this bug: 1799087
Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1825017
Resolution: --- → DUPLICATE
Assignee: nobody → richard.marti
Status: RESOLVED → REOPENED
No longer duplicate of bug: 1825017
Resolution: DUPLICATE → ---
Target Milestone: --- → 113 Branch
Status: REOPENED → ASSIGNED
Duplicate of this bug: 1825017

Thanks much Richard for fixing this annoying usability issue.
Per my comment 0, 102 is also affected, and this is safe and simple enough for a worthwhile uplift.

Pushed by micah@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/53430a67cfee
Address Book: Make the edit panel resizeable. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago1 year ago
Resolution: --- → FIXED

Comment on attachment 9325510 [details]
Bug 1815953 - Address Book: Make the edit panel resizeable. r=aleca

[Approval Request Comment]
User impact if declined: AB card in edit mode not resizeable
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9325510 - Flags: approval-comm-beta?

102 has no splitters. So this patch can't land there.

Comment on attachment 9325510 [details]
Bug 1815953 - Address Book: Make the edit panel resizeable. r=aleca

[Triage Comment]
Approved for beta

Attachment #9325510 - Flags: approval-comm-beta? → approval-comm-beta+

(In reply to Richard Marti (:Paenglab) from comment #8)

102 has no splitters. So this patch can't land there.

You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: