Closed Bug 1815971 Opened 1 year ago Closed 11 months ago

Add telemetry for how often we see search terms in the urlbar and how often it needs to be reverted due to a shown PopupNotification

Categories

(Firefox :: Address Bar, task, P2)

task

Tracking

()

RESOLVED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: jteow, Assigned: jteow)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

Attachments

(2 files)

Bug 1812232 found PopupNotifications while the search terms persist would not show properly because they expected elements to be there.

So to address that, we now revert the urlbar anytime a notification is shown. However, that might affect the usage of the feature, so we should compare how often search terms are shown to the user vs. how often we need to revert the urlbar due to a notification being shown.

See Also: → 1815973

I think it depends on Bug 1815769, because we don't want to just track if the urlbar was reverted, we want to know specifically that it was because of an impending PopupNotification.

Depends on: 1815769
Assignee: nobody → jteow
Status: NEW → ASSIGNED
Attachment #9324108 - Flags: data-review?(jhirsch)

Comment on attachment 9324108 [details]
data-collection-review-1815971.md

data-review+


  1. Is there or will there be documentation that describes the schema for the ultimate data set in a public, complete, and accurate way?

Yes, the usual desktop telemetry data docs at https://probes.telemetry.mozilla.org/.

  1. Is there a control mechanism that allows the user to turn the data collection on and off? (Note, for data collection not needed for security purposes, Mozilla provides such a control mechanism) Provide details as to the control mechanism available.

Yes, the usual desktop telemetry opt-out controls in about:preferences.

  1. If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, jteow will monitor.

  1. Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, interaction data.

  1. Is the data collection request for default-on or default-off?

Default-on.

  1. Does the instrumentation include the addition of any new identifiers (whether anonymous or otherwise; e.g., username, random IDs, etc. See the appendix for more details)?

No.

  1. Is the data collection covered by the existing Firefox privacy notice?

Yes.

  1. Does the data collection use a third-party collection tool?

No.

Attachment #9324108 - Flags: data-review?(jhirsch) → data-review+
Pushed by jteow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/460ee1151eb8
Count number of times persisted search is viewed and reverted due to Popups - r=adw
Regressions: 1823956
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
You need to log in before you can comment on or make changes to this bug.