Closed Bug 1817083 Opened 1 year ago Closed 1 year ago

When loading a message, the screen reader reads the subject 3 times

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 111
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: thomas8, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, Whiteboard: [Supernova3p])

From Elizabeth's accessibility analysis:

When loading a message, the screen reader reads the subject 3 times

112.0a1 (2023-02-15) (64-bit), Win10

STR

  • Select a msg in thread pane (or else open it in a tab)

Actual:

  • When loading a message, the screen reader reads the subject 3 times (reports Elizabeth)
  • In my tests on 112.0a1 (2023-02-15) (64-bit), Win10 inbuilt screen reader read it once from message list, and later one more time saying: "<Subject> was loaded". So that's 2 times in total. Maybe the "... was loaded" information had a purpose?

Expected

  • Consider reading the subject only one time
Type: defect → enhancement
See Also: → 1817095

Unless I misunderstand, this is a regression compared to version 102, and therefore a defect.

I suggest that bug reports should be recorded in bugzilla as defects if they are regressions when compared to version 102 functionality, and should trump any notion that they are merely improvements to supernova's baseline functionality. Also, people who are looking for "bugs" that they are experiencing may likely overlook issues reported as enhancements.

Type: enhancement → defect
Keywords: regression

Does this still happen?

Flags: needinfo?(elizabeth)

This is not a regression. I just tested this in 102 and 113. This is improved from when this was initially tested.

Testing on Windows 11 with NVDA.

For opening a message in its own tab:

102:
In 102, using NVDA in Windows, the user hears:
"[Subject] - Inbox [email address] - Mozilla Thunderbird"
"[Subject]"
"[Subject]"

113:
In 113, it appears this is happening because the screen reader is giving a status update before the content loads. So while it sounds like the message subject is being repeated, it is just that the status update is interrupted. This sometimes is repeated and is sometimes not. At the most basic, the user will hear in NVDA in Windows:
"[Subject] Thunderbird Daily" - (This is while it is loading)
"Home Thunderbird Daily - [Subject] Grouping - [Subject] - [Message]"

For opening a message in the message pane:

102:
"Banner Landmark" - (jumps to toolbar for message)

113:
The user hears:
"[Subject] Grouping"
"Banner Landmark"

This seems good to me, as it gives the user some context.

Flags: needinfo?(elizabeth)
Keywords: regression
Whiteboard: [Supernova] → [Supernova3p]

I can't reproduce this anymore.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.