Closed Bug 1817705 Opened 1 year ago Closed 7 months ago

Convert to event/task missing from context menu

Categories

(Calendar :: General, defect, P3)

Thunderbird 113

Tracking

(thunderbird_esr102 unaffected, thunderbird_esr115 fixed, thunderbird116 wontfix, thunderbird117 fixed)

RESOLVED FIXED
118 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird_esr115 --- fixed
thunderbird116 --- wontfix
thunderbird117 --- fixed

People

(Reporter: mkmelin, Assigned: elijmitchell)

References

(Blocks 1 open bug, Regressed 1 open bug, )

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

Convert to event/task is missing from the context menu. It is available on the More button though.

Duplicate of this bug: 1821902

It is available on the More button, but it is broken.

No longer duplicate of this bug: 1821902
See Also: → 1821902
Duplicate of this bug: 1824122
Whiteboard: [Supernova] → [Supernova3p]
Duplicate of this bug: 1836145

Will it return in the Message List > Message context menu at some point? When?
This is where it is the most practical to find and use.

Flags: needinfo?(alessandro)
See Also: → 1776462
Assignee: nobody → elizabeth
Blocks: sn-msglist
Severity: -- → N/A
Flags: needinfo?(alessandro)
Priority: -- → P3
Status: NEW → ASSIGNED

I can confirm that this is still an issue on v115.0b4, however the option in the "More" menu does currently work.

Old Related bugs:
https://bugzilla.mozilla.org/show_bug.cgi?id=1642580
https://bugzilla.mozilla.org/show_bug.cgi?id=1690900

I am more interessted in, is the Caldav bug Bug 1815849 or Bug 1776462 solved in this later Versions V1150b5?

See Also: → 1642580
See Also: → 1690900
Attachment #9341929 - Attachment description: WIP: Bug 1817705 - Add Convert To Event and Task in mail context menu. → Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers
Attachment #9341929 - Attachment description: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers → WIP: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers
Attachment #9341929 - Attachment description: WIP: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers → Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers
Attachment #9341929 - Attachment description: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers → WIP: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers
Attachment #9341929 - Attachment description: WIP: Bug 1817705 - Add Convert To Event and Task in mail context menu. r=#thunderbird-front-end-reviewers → Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers
Severity: N/A → S3
Version: unspecified → Thunderbird 113
Attachment #9341929 - Attachment description: Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers → WIP: Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers
Attachment #9341929 - Attachment description: WIP: Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers → Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers

Instead of

+    // Show only if a message is actively selected in the DOM.
+    let showConvertMenu =
+      numSelectedMessages == 1 && !this.selectionIsOverridden;
+    showItem("mailContext-calendar-convert-menu", showConvertMenu);

why don't you use:

+    setSingleSelection(
+      "mailContext-calendar-convert-menu",
+      !this.selectionIsOverridden
+    );
Attachment #9341929 - Attachment description: Bug 1817705 - Add convert to event/task in mail context menu. r=#thunderbird-front-end-reviewers → Bug 1817705 - Add convert to event/task in mail context menu. r=aleca

Comment on attachment 9341929 [details]
Bug 1817705 - Add convert to event/task in mail context menu. r=aleca

[Approval Request Comment]
Regression caused by (bug #): N/A, changes from 102 to 115.
User impact if declined: Users used the context menu in 102 to convert an email to an event or task. This restores that functionality for 115+. Without this, users may complain that this feature is not present. It could interrupt their expected workflow.
Testing completed (on c-c, etc.): Tested on try-comm-central and locally.
Risk to taking this patch (and alternatives if risky): Low risk.

Attachment #9341929 - Flags: approval-comm-esr115?
Attachment #9341929 - Flags: approval-comm-beta?
Target Milestone: --- → 118 Branch

Comment on attachment 9341929 [details]
Bug 1817705 - Add convert to event/task in mail context menu. r=aleca

[Triage Comment]
Approved for beta

Attachment #9341929 - Flags: approval-comm-beta? → approval-comm-beta+

Pushed by brendan@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/ee6ba98248ba
Add convert to event/task in mail context menu. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Summary: convert to event/task missing from context menu → Convert to event/task missing from context menu

Comment on attachment 9341929 [details]
Bug 1817705 - Add convert to event/task in mail context menu. r=aleca

[Triage Comment]
Approved for esr115

Attachment #9341929 - Flags: approval-comm-esr115? → approval-comm-esr115+
See Also: → 1855372
Regressions: 1855372
You need to log in before you can comment on or make changes to this bug.