Closed Bug 1690900 Opened 2 years ago Closed 2 years ago

Convert email to task/event is broken since 2021-01-20

Categories

(Thunderbird :: General, defect)

Thunderbird 87
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird86+ verified)

VERIFIED FIXED
87 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird86 + verified

People

(Reporter: sdk, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(1 file)

Step to reproduce

  1. Right-click on an email in the message list
  2. Choose "Convert To"
  3. Choose "Event" or "Task"

Expected behavior

A new window to configure the event or task should open

Actual behavior

Nothing happens.

Additional information

I did a mozregression and this regression has been introduced by:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=47627b7a5b34d04816233abe24bf4051b8ac807c&tochange=be365d09c14b55f717bdf633cf48dbb6a27a3754

I also tried with browser.tabs.remote.autostart set to false but the issue persists.

Curious, there is already a bug report from mid-December: Bug 1682895

Error Console:
| Lightning: Your installed Lightning only includes a single locale, extracting event info from other languages is likely inaccurate. You can install Lightning from addons.mozilla.org manually for multiple locale support. calExtract.jsm:47

Curious warning, but it always comes up together with the next error message.

| Uncaught ReferenceError: GetMessagePaneFrame is not defined
| extractFromEmail chrome://calendar/content/calendar-extract.js:118
| oncommand chrome://messenger/content/messenger.xhtml:1
| calendar-extract.js:118:15

(In reply to Alfred Peters from comment #1)

Curious, there is already a bug report from mid-December: Bug 1682895

Looks more like a coincidence. The application doesn't crash in my case.

Curious warning, but it always comes up together with the next error message.

I only get the Uncaught ReferenceError: GetMessagePaneFrame is not defined on my side and AFAIK it'd make sense if it's related to e10s. I'm guessing it prevents communication between both parts of the code.

(In reply to Danny Colin [:sdk] from comment #0)

I did a mozregression and this regression has been introduced by:
https://hg.mozilla.org/comm-central/pushloghtml?fromchange=47627b7a5b34d04816233abe24bf4051b8ac807c&tochange=be365d09c14b55f717bdf633cf48dbb6a27a3754

Let's see what Geoff Lankow has to say about it. Geoff?

Flags: needinfo?(geoff)

I removed GetMessagePaneFrame, so that'll be why it's not working!

Assignee: nobody → geoff
Status: NEW → ASSIGNED
Flags: needinfo?(geoff)
Regressed by: tb-fission

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9aa3f607e4b6
Fix converting messages to events. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

Comment on attachment 9201967 [details]
Bug 1690900 - Fix converting messages to events. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #): tb-fission
User impact if declined: converting mail to events won't work
Testing completed (on c-c, etc.): landed 3 days ago
Risk to taking this patch (and alternatives if risky): no

Attachment #9201967 - Flags: approval-comm-beta?

Comment on attachment 9201967 [details]
Bug 1690900 - Fix converting messages to events. r?mkmelin

[Triage Comment]
Approved for beta

Attachment #9201967 - Flags: approval-comm-beta? → approval-comm-beta+
Summary: Convert to is broken since 2021-01-20 → Convert email to task/event is broken since 2021-01-20

TB 86.0b3 on Windows 10

Followed reporters STR for a credit card payment due on 02/20

The Event dialog opened with a start date of 2/20 and an end date of 2/28.

Converting the email to a task the start date was 02/13 @ 5:23 AM, due on 2/21@ 5:23 AM.

The same occurs using the Fedora supplied 78.7.0 on Fedora 33.

Since I never use this is that the expected result?

Flags: needinfo?(contact)

(In reply to WaltS48 [:walts48] from comment #14)

Since I never use this is that the expected result?

On my side, both set the start date to today's date. Maybe there's something special with your email. Maybe there's something similar to "add this event to your calendar" banner you get with google calendar invitation.

Oh and btw, darktrojan patch fixed my issue :)

Flags: needinfo?(contact)

Not a Google invite, but a bank email with the due date of my credit card payment.

Event starts on the Due date, task on the date I received the email. Both are editable.

Since your issue is resolved.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.