Closed Bug 1817867 Opened 1 year ago Closed 1 year ago

`Restore Column Order` of thread pane doesn't do anything

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird111? fixed)

RESOLVED FIXED
112 Branch
Tracking Status
thunderbird111 ? fixed

People

(Reporter: thomas8, Assigned: aleca)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

112.0a1 (2023-02-20) (64-bit)

Thread pane columns on IMAP were acting up, showing wrong set of columns in wrong order (all small columns in front, as in bug 1612055), and thread column gone (restorable). So I tried "Restore Column Order", which did nothing.

If anyone can reproduce, kindly let me know.

STR

  • Hide and show some columns of threadpane (e.g. Correspondents) from column picker, so that you don't have the default set. We need a non-default column order - for me it just happened, not sure how to force that as we cannot reorder columns yet.
  • From column picker, choose "Restore Column Order".

Actual

  • Nothing

Expected

  • Reorder all chosen columns in default order

Btw: Why don't we have "Restore default set of columns"??

Blocks: 1817871
No longer blocks: 1817871
See Also: → 1803272

I can't reproduce this bug.
Clicking "Restore column order" works for me.

EDIT: Nevermind, I was able to reproduce it.
This used to work since I implemented it, something regressed it recently.
I'm also working on re-enabling the tests for this so we can hopefully avoid further breakages.

Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Target Milestone: --- → 112 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/e961caf59301
Fix the restore column order options. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9318855 [details]
Bug 1817867 - Fix the restore column order options. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9318855 - Flags: approval-comm-beta+
Whiteboard: [Supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: