Closed Bug 1817899 Opened 1 year ago Closed 1 year ago

UrlbarProviderWeather returns an unknown result type

Categories

(Firefox :: Address Bar, defect, P2)

defect

Tracking

()

VERIFIED FIXED
112 Branch
Tracking Status
firefox112 --- verified

People

(Reporter: daisuke, Assigned: daisuke)

References

Details

Attachments

(1 file)

This is a follow-up for bug 1817202.
As commented in https://bugzilla.mozilla.org/show_bug.cgi?id=1817202#c2, as we had not supported UrlbarProviderWeather, the result type will be unknown.
To fix it, we will introduce weather result type.

Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Summary: UrlbarProviderContextualSearch returns an unknown result type → UrlbarProviderWeather returns an unknown result type

Depends on D170470

Attachment #9318920 - Attachment description: Bug 1817899: Introduce weather result type → Bug 1817899: Introduce weather in the result type
Severity: -- → N/A
Priority: -- → P2
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/905d9c6d01ea
Introduce weather in the result type r=mak
Severity: N/A → S3
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch

The issue is verified fixed using the latest Fx 112.0a1 on Windows 10 and Ubuntu 22.04. "Weather" is correctly listed in the result type for engagement, impression and abandonment telemetry pings, when the weather suggestions is displayed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.