Closed Bug 1818060 Opened 1 year ago Closed 10 months ago

Sometimes the visually selected row is not really the selected row

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected, thunderbird112 affected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird112 --- affected

People

(Reporter: soeren.hentzschel, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

I don't have steps to reproduce since it only happens sometimes. But sometimes the row that is visually selected is not the really selected row in the new message list.

Please see this video:

https://www.youtube.com/watch?v=BjnWQO8WXro

You can see that one row has the background color for a selected row. Then I press the 'S' key several times to mark and unmark the message with a star icon. As you can see not the star icon of the row with the backgroud color changes its state but the row above.

Tested in Thunderbird Daily 112.0a1 (2023-02-21) on macOS 13.2.

Keywords: regression
Whiteboard: [Supernova]
Version: Trunk → Thunderbird 112
Depends on: 1819795

I can verify this. In one instance replying to the visually selected message created a reply message to the message one above the visually selected message.

(In reply to Steve Edmonds from comment #1)

I can verify this.

Was that with With beta? or with daily?

Flags: needinfo?(steve)

Sören, are you still seeing this after 03-03 daily, when bug 1819795 was fixed?

Flags: needinfo?(soeren.hentzschel)

Since it only happened sometimes and I don't know when I saw this the last time I can't tell for sure. I'll keep the needinfo? request for a few days.

A few moments ago it happened again in Thunderbird Daily 113.0a1 (2023-03-19).

Flags: needinfo?(soeren.hentzschel)

(In reply to Wayne Mery (:wsmwk) from comment #2)

(In reply to Steve Edmonds from comment #1)

I can verify this.

Was that with With beta? or with daily?

The beta.

Flags: needinfo?(steve)

happening still with nightly or 112.0b5 ?

Yes, I saw this a few times today with Thunderbird Daily 113.0a1 (2023-03-29).

I am on 112.0b5 (64-bit), Windows, and I can reproduce this issue by sending an email to myself (using an external email client, for example on my phone) while having a message selected. Once I receive the message, actions (starring, reply, ...) affect the row above instead of the actual e-mail.

Whiteboard: [Supernova] → [Supernova3p]

Does this still happen? Smells like a dupe of Bug 1823637 to me.

That's fixed in 113.0b3 and above. Sören, can you verify?

I am not sure since this only happened sometimes but I didn't see this in Thunderbird Daily in the last few days. I'll let you know if I see this again.

If it is still gone, you can click WORKSFORME, then Save Changes

Flags: needinfo?(soeren.hentzschel)
Status: NEW → RESOLVED
Closed: 10 months ago
Flags: needinfo?(soeren.hentzschel)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.