names of saved files are random strings

RESOLVED WORKSFORME

Status

Camino Graveyard
Downloading
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: kevin+mozilla, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

When I download and save files, regardless of the name I specify in the download
dialog, the file is saved on my computer with what appears to be a randomly
generated string of characters as the name.  E.g., efgxyrkh.pdf.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




I've experienced this with Chimera 0.5 and 0.6.  Other people I know using these
versions do not experience this.  I'm using fairly old hardware (a beige G3),
and although it seems unlikely to me that this could be related, it's the only
relevant difference I can think of.

Comment 1

16 years ago
Are you saying when the download finishes the files still have the random name?
 Files have random names while they are being downloaded by design.  When the
download finishes the file should be renamed to the specified name.
(Reporter)

Comment 2

16 years ago
That's correct.  The renaming never occurs.  The end result is a file in my
download directory with a random name.

Comment 3

16 years ago
Odd. AFAIK this is the only report of this problem.  I'm out on vacation all
this week but perhaps Chris Petersen, the QA engineer for download issues, can
work with you to figure out what's different on your system.

Comment 4

16 years ago
Yes, I've seen this, too, as recently as yesterday using Chimera/2002112204.
I'll try to come up with a way to reliably reproduce it.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
any further updates on this bug?

Comment 6

16 years ago
Need to know if this still happens.
(Reporter)

Comment 7

16 years ago
Are you (Steve and Simon) asking me if it still occurs?  If so, well, yes,
because I'm still using the same production release.  If no one else is
monitoring this issue on the daily builds (Greg?), then I suppose I could
install the latest and greatest to check it out.

Comment 8

16 years ago
Please do.
(Reporter)

Comment 9

16 years ago
I just upgraded to the Dec 20 build and the problem still occurs there.

Comment 10

16 years ago
While the file is downloading, the file names are supposed to be random strings
(for security reasons). Just to confirm: you're saying that, when the download
finishes, the file doesn't get renamed to the proper name? What does the 'Show
in Finder' button in the download window do when the download has finished?
(Reporter)

Comment 11

16 years ago
Yes, as I confirmed in comment #2, in response to comment #1, the file is never
renamed.

Comment 12

16 years ago
Actually- I too have this problem

I just downloaded two files using 0.7, they are named:
qfgp23sh.sit, h2z8xezw.binary

Big potential hint: my home directory is mounted from an X server?

Comment 13

15 years ago
I'm having this same problem.  Every file I download on any of the computers on
the network ends up with names like "3w9e70ta.zip"  Interestingly, in the little
download window it gives the correct filename in the "destination" field.

My home directory (into which I am downloading) is also on a network volume. 
Maybe this is the problem (camino has had problems with network homes before?)

PS:  I am running Camino 0.7 Build ID 2003030613

Comment 14

15 years ago
Yes, I'd seen this too on my Mac that has a network volume as its home
directory. This seemed to be fixed somewhere is the later days of .7, but is
back now.
(Reporter)

Comment 15

15 years ago
hmm... My users homes, application, and system root are all seperate partitions,
albeit local.

Maybe this is at the root of the problem.

Comment 16

15 years ago
That's likely, yes.

Comment 17

15 years ago
*** Bug 209645 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
*** Bug 192778 has been marked as a duplicate of this bug. ***

Comment 19

15 years ago
-> pinkerton
Assignee: sdagley → pinkerton
(Assignee)

Comment 20

15 years ago
does this still happen with nightly builds?
(Assignee)

Comment 21

15 years ago
gonna mark wfm since nobody will confirm if it still happens. please reopen if
it does with nightly builds.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 22

15 years ago
When you say "works for me", do you mean that you have actually tried on the
specified configuration (home/download directory on a separate partition) and
reproduced with an old version, then confirmed it no longer happens with a
current version?

If not, I'll try to find the time to install a nightly sometime soon.
(Assignee)

Comment 23

15 years ago
please test this. i cannot and nobody would answer when i asked them to. feel
free to reopen if this still occurs.
You need to log in before you can comment on or make changes to this bug.