Closed Bug 1819953 Opened 1 year ago Closed 1 year ago

Color customization of folders in folder pane is only applied after restart of TB

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED FIXED
113 Branch
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: thomas8, Assigned: micah)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Supernova3p])

Attachments

(1 file)

From TB-106.

Color customization of folders in folder pane is only applied after restart of TB (also affects Restore default color).
Confirmed for 112.0a1 (2023-03-02) (64-bit), Win10.

STR

  • Right-click on folder in folder pane > Properties
  • Change folder color and confirm (by analogy, same problem for Restore default color).

Actual

  • Folder color remains unchanged until restart of TB

Expected

  • Folder color change should be applied instantly (also for Restore default color)

Devs, you may want to provide a hint for fixing this, and to add keyword good-first-bug if it is.

Assignee: nobody → micah
Duplicate of this bug: 1823544
Attachment #9325818 - Attachment description: WIP: Bug 1819953 - Reload folder pain on folder color change. → Bug 1819953 - Update folder icon color on folder color change. r=aleca,darktrojan
Status: NEW → ASSIGNED
Target Milestone: --- → 113 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f66025dee43a
Update folder icon color on folder color change. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Whiteboard: [supernova] → [Supernova3p]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: