QuickSearch should search on To/cc fields in addition to subject & sender

RESOLVED DUPLICATE of bug 189241

Status

SeaMonkey
MailNews: Message Display
--
enhancement
RESOLVED DUPLICATE of bug 189241
16 years ago
10 years ago

People

(Reporter: jonathan.courtney, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021126
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.3a) Gecko/20021126

(This RFE is prompted by the removal of the "Advanced" search button from the
QuickSearch bar.  See Bug 179953.)

Users who are are subscribed to multiple email aliases can receive lots of mail
with the alias name in the To/cc fields -- rather than their own email address
in those fields.  Searching on the To/cc fields can become a commonplace
activity since these fields now have more meaningful information (for sorting)
than the Subject and Sender fields.

The recent removal of the "Advanced" search button from the QuickSearch bar has
added an extra step to this activity.  Since the Advanced button was
intentionally removed, this request is to ADD To/cc to the default QuickSearch
function, i.e. please make QS field search on Subject, Sender and To/cc.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

16 years ago
I would think this should be an option, not necessarily automatically included.
Also, you can use a customized view (views dropdown on search toolbar - new
feature) or filter on To or CC to locate certain alias messages.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
Regarding using a customized view: Your point is well taken, although this
requires that the criteria for the view be set up in advance and retained
afterward.  That is considerably more heavyweight than what I had in mind,
particularly since there are a large number of email lists from which I receive
messages -- it would  make for a long "view" menu.  Something more like "fire
and forget" search would be more desirable.
mass re-assign.
Assignee: naving → sspitzer
scott, what do you think about adding other email fields to the quick search?

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 244325 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 6

13 years ago
not resolved by solution to bug 244325, therefore not a dupe.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

13 years ago

*** This bug has been marked as a duplicate of 189241 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → DUPLICATE

Comment 8

12 years ago
*** Bug 331379 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.