Closed Bug 1820820 Opened 1 year ago Closed 11 months ago

Closing the picture-in-picture window with a paused video from air.mozilla.org will automatically continue playing

Categories

(Toolkit :: Picture-in-Picture, defect)

defect

Tracking

()

VERIFIED FIXED
113 Branch
Tracking Status
firefox113 --- fixed

People

(Reporter: whimboo, Assigned: kisavi, Mentored)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/112.0 ID:20230301225323

Closing the PiP window with a paused video from air.mozilla.org should not automatically continue playing the video which is disruptive.

Steps:

  1. Open a video from air.mozilla.org like one from Joy of code
  2. Start playing the video
  3. Move the video into a PiP window
  4. Stop playing the video
  5. Close the PiP window

With step 5 the video should have been moved back to the original location and keeps the paused state. But instead it continues playing.

When closing the PiP window, we normally pause the video. However, videoWrapper pause methods take priority. The airmozilla wrapper was updated recently to sync the unmute/mute and play/pause buttons, but we select the pause/play button regardless of a video's paused state.

We should make sure to do the following in airmozilla.js:

  1. We only select the play/pause button for play if a video is paused
  2. We only select the play/pause button for pause if a video is playing
Keywords: good-first-bug
Severity: -- → S3
Mentor: kpatenio

Hey, I am an outreachy applicant and would like to work on this issue, I'm looking into it. Please assign this to me.

Hello Mark. My name is Yusuf, and i am also an outreachy applicant participating for outreachy internship program. Please assign me to work on this issue in order to make my first contribution for this project.

Hi, thank you both for your interest.

(In reply to Siya from comment #2)

Hey, I am an outreachy applicant and would like to work on this issue, I'm looking into it. Please assign this to me.

I saw that you commented in Bug 1821305. If you're actively working on that bug, please continue to work on it. I would like to keep this open for someone that is still looking for a bug.

(In reply to yusufjakada5 from comment #3)

Hello Mark. My name is Yusuf, and i am also an outreachy applicant participating for outreachy internship program. Please assign me to work on this issue in order to make my first contribution for this project.

I saw that you commented in Bug 1821296. If you're actively working on that bug, please continue to work on it. I would like to keep this open for someone that is still looking for a bug.

Hi Yusuf, I noticed that the bug you commented in was recently fixed. Are you still looking for a bug?

Flags: needinfo?(yusufjakada5)

Hello @kpatenio. My name is Denis and I am an Outreachy intern. I would like to be assigned to work on this bug if it is still open and unassigned.

(In reply to dev from comment #6)

Hello @kpatenio. My name is Denis and I am an Outreachy intern. I would like to be assigned to work on this bug if it is still open and unassigned.

Hi Denis. Thanks for your interest. I haven't heard back from Yusuf about this bug, so you may take it. Please reach out if you have any questions. Otherwise if there's no activity on the bug after a couple days, I might unassign the ticket to give other applicants a chance to work on a patch.

Assignee: nobody → deniskisavi
Status: NEW → ASSIGNED
Flags: needinfo?(yusufjakada5)

Hello @kpatenio. Thank you for your response.This is my first time contributing to open source and I am really excited to be presented with this opportunity. I will surely reach out for any queries or concerns I will be having. Thank you once again

Hello @kpatenio and henrik. How do I play/open the video in another tool like VLC player because if I click on the joy of code link, it opens the video but I am unable to recreate the problem by putting the video in a PIP window. So I was hoping maybe there is a way to play the video on another application like VLC. I am on Ubuntu. Thank you.

I have followed the steps for recreating the issue but as you can see on this screen record I have attached, everything seems to work fine. Or am I missing something?

Flags: needinfo?(kpatenio)

Hi Denis, thanks for the recording. The Picture-in-Picture window looks different in the recording. This ticket is for Firefox's Picture-in-Picture feature. Are you able to view PiP on Firefox?

Flags: needinfo?(kpatenio) → needinfo?(deniskisavi)

Sorry about the confusion earlier and thank you for the clarification. I was opening the video in another browser. I have successfully been able to regenerate the problem on Firefox. Can I kindly request guidance on how to locate and solve the bug? This is my first time doing this. Thank you.

Flags: needinfo?(deniskisavi)

(In reply to dev from comment #12)

Sorry about the confusion earlier and thank you for the clarification. I was opening the video in another browser. I have successfully been able to regenerate the problem on Firefox. Can I kindly request guidance on how to locate and solve the bug? This is my first time doing this. Thank you.

No problem and thanks for the confirmation. Do you have a local build of Firefox set up? If not, consult this guide. If you have trouble with your build, check out the Introduction Matrix channel if you aren't there already.

Otherwise, please take a look at the airmozilla file that I mentioned in comment 1 of this ticket. The searchfox link I added for that file also highlights lines relevant to this bug and can help you get started. Once you made the fix, you can submit a patch through Phabricator and set me as a reviewer.

No problem, and yes, I have a local build which I managed to setup successfully. Let me start working on the issue. Thank you

Hello @kpanenio. I wanted to submit the patch. I have set up Phabricator and Moz-Phab successfully but I have an issue with how am supposed to do the commit message. Do I do a normal git add & git-commit then run this command moz-phab [start_rev] [end_rev] or how exactly do I do it. Thank you

Because the instrusctions on the repo tells me to run git commit/hg commit so am wondering if I should skip the git add command and also, won't it bring an issue if I pushed without doing a pull first. Thank you

(In reply to dev from comment #15)

Hello @kpanenio. I wanted to submit the patch. I have set up Phabricator and Moz-Phab successfully but I have an issue with how am supposed to do the commit message. Do I do a normal git add & git-commit then run this command moz-phab [start_rev] [end_rev] or how exactly do I do it. Thank you

(In reply to dev from comment #16)

Because the instrusctions on the repo tells me to run git commit/hg commit so am wondering if I should skip the git add command and also, won't it bring an issue if I pushed without doing a pull first. Thank you

Hi Denis, it sounds like you're using git for your setup. I don't use git for Firefox development, but I believe you need git add to stage your changes for the next commit you make via the git commit command. As for moz-phab, you only need to run moz-phab submit after making your commit. And yes, it's normally a good idea to run git pull (or the mercurial equivalent hg pull) from mozilla-central to keep up with the latest version.

For future questions concerning version control and moz-phab, I recommend posting your questions on the Introductions channel I mentioned earlier (if you haven't done so already). People in this channel will be able to help you faster and may even know more about git for Firefox than I do. (Plus, due to time zones differences, I unfortunately won't be able to respond right away). I will be able to guide you on steps specific to the bug itself though.

Hi Kate. I asked for assistance in the group and guys were gracious enough to offer help. I was able to submit a patch here https://phabricator.services.mozilla.com/D172963 and added you as a reviewer. Kindly let me know if there is anything I am supposed to change. Thank you.

Attachment #9323862 - Attachment description: WIP: Bug 1820820 - Update how the playPause button is selected. r?kpatenio → Bug 1820820 - Update how the playPause button is selected for airmozilla wrapper. r?kpatenio
Pushed by kpatenio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7e3f8a824b1
Update how the playPause button is selected for airmozilla wrapper. r=kpatenio
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 113 Branch
Flags: qe-verify+

Reproduced the issue with Firefox 112.0a1 (2023-03-07) on macOS 12 and Windows 10.
The issue is verified fixed with Firefox 114.0a1 (20230426170915) and Firefox 113.0b8 (20230425192707) on Windows 10, macOS 12 and Ubuntu 22.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.