When a download is in progress, disconnecting from internet causes to indicate 100% done in DM

RESOLVED DUPLICATE of bug 142666

Status

SeaMonkey
Download & File Handling
RESOLVED DUPLICATE of bug 142666
15 years ago
9 years ago

People

(Reporter: Joe Young, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

After reconnecting, download status said that it had completed the 10,000kb
download. Went to My Download folder and found only 3,900kb was in the 1.2 file.
I knew that it had not completed, but clicked anyway, received failure notice,
which was not unexpected. Think that the download should have actually taken up
where it was interrupted as with other download programs.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.




With downloads using modems and slower systems, I would like to not have to
re-do the download when it's 30% completed.

Comment 1

15 years ago
Reassigning to leaf.

mitchell
Assignee: mitchell → leaf
QA Contact: mitchell → endico
Summary: On download of latest version, 1.2, was disconnected from internet after 15 minutes of download, 3,900KB was downloaded. → On download, was disconnected from internet after 15 minutes of download, 3,900KB was downloaded.

Comment 2

15 years ago
this is most likely invalid - mozilla is not a download agent.
Target Milestone: --- → Future

Comment 3

15 years ago
actually, should be installer - over to the installer product if they want to
work on this at some point.
Component: Miscellaneous → Installer
Product: mozilla.org → Browser
Target Milestone: Future → ---
Version: other → Trunk

Comment 4

15 years ago
to default component owner.
Assignee: leaf → ssu
QA Contact: endico → bugzilla
Product: Browser → Seamonkey

Comment 5

13 years ago
Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.5) Gecko/20041217
I was about to report this bug for Mozilla 175, while downloading Mozilla177 it
was interrupted - download manager shows "11744KB of 11744KB" but if you look at
the actual file only 2.5M was downloaded.  I have seen this numerous times where
it reports an interrupted download as complete.  I suspect it may be related to
using a proxy - I'm running Junkbuster on the local machine, but it clearly
knows the expected file size and should know that its not complete.  I've seen
other cases where, because the client->proxy connection is not the one that
failed, the client is unaware the end to end connection failed.

I question the assignment to installer if I'm reading the report correctly its a
problem with Download Manager.

Comment 6

12 years ago
Original summary: "On download, was disconnected from internet after 15 minutes of download, 3,900KB was downloaded."

This has nothing to do with the installer, see bug 168846.
Component: Installer → Download Manager
Depends on: 168846
Summary: On download, was disconnected from internet after 15 minutes of download, 3,900KB was downloaded. → When a download is in progress, disconnecting from internet causes to indicate 100% done in DM

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 142666
You need to log in before you can comment on or make changes to this bug.