Closed Bug 1823264 Opened 11 months ago Closed 10 months ago

thread list is not redrawn when moving multiple messages

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 112
defect

Tracking

(thunderbird_esr102 unaffected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr102 --- unaffected

People

(Reporter: justbecuz, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: dupeme, Whiteboard: [Supernova3p])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:109.0) Gecko/20100101 Firefox/110.0

Steps to reproduce:

select multiple messages in the inbox, right-click and move messages to a remote folder

Actual results:

messages were moved but still appeared in message list in inbox

Expected results:

message pane should have been redrawn to show updated list. note: pressing the alt key to quickly toggle the menu is enough to trigger a redraw and show the updated message list

Keywords: dupeme
Whiteboard: [Supernova]

The list of messages is referred to as the thread pane.
In general that is working I think. Which kind of account is it, and are you applying quick filtering etc?

Component: Untriaged → Folder and Message Lists
Summary: message pane is not redrawn when moving multiple messages → thread list is not redrawn when moving multiple messages

(In reply to Magnus Melin [:mkmelin] from comment #1)

The list of messages is referred to as the thread pane.
In general that is working I think. Which kind of account is it, and are you applying quick filtering etc?

justbecuz, can you provide some more information?

Blocks: sn-msglist
Severity: -- → S3
Flags: needinfo?(justbecuz)

It's a Google account. No quick filtering is used.

Again, this has nothing to do with the actual behavior concerning messages actually being moved to the proper folder. It's just a display issue. It seems the command to redraw the thread list is not called when multiple messages are moved to a folder.

Flags: needinfo?(justbecuz)
Whiteboard: [Supernova] → [Supernova3p]

Justbecuz, do you still see this when using 113.0b6?

Flags: needinfo?(justbecuz)

Looks like this is fixed! I just tried selecting multiple messages and moving them back and forth between a couple of folders, and the display updated properly each time. Thank you!

Flags: needinfo?(justbecuz)
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.