Closed Bug 1823418 Opened 1 year ago Closed 1 year ago

Scrollbars show through to GMail Context menus

Categories

(Core :: Layout: Scrolling and Overflow, defect)

Desktop
All
defect

Tracking

()

RESOLVED DUPLICATE of bug 1827337

People

(Reporter: mkaply, Unassigned)

References

(Regression)

Details

(Keywords: regression, regressionwindow-wanted)

Attachments

(2 files)

Attached image Screenshot on Windows

On Windows and macOS, if the left sidebar rail in gmail has a scroll bar, it shows through the context menu displayed in gmail.

This doesn't happen in Chrome.

Attached image Problem on macOS
Attachment #9323970 - Attachment description: image (2).png → Screenshot on Windows

On Windows11, I can reproduce this issue.
And the problem is gone if setting widget.windows.overlay-scrollbars.enabled to false.

On Ubuntu20.04, I can also reproduce this.
And the problem is gone if setting widget.gtk.overlay-scrollbars.enabled to false.

OS: Unspecified → All
Hardware: Unspecified → Desktop

I ran mozregression on macOS, and can reproduce this on a 2022-04-04 build (20220404231805). On macOS, this only happens with overlay scrollbars, not "always visible" scrollbars. The regressor in comment 3 is correct as it seems to enable overlay scrollbars on Windows. but the issue itself is not new.

There is probably an existing issue on the z order of scrollbars but I can't find it right now, I know what change needs to be made, just need to read the history of the code to make sure it is correct and there is nothing depending on it.

QA Whiteboard: [qa-regression-triage]

(In reply to Timothy Nikkel (:tnikkel) from comment #6)

There is probably an existing issue on the z order of scrollbars but I can't find it right now

I think the bug you're looking for is bug 1803910.

Severity: -- → S3
Depends on: 1803910
See Also: → 1827017
Depends on: 1827337

Should be fixed now on nightly. Can you confirm?

Flags: needinfo?(mozilla)
See Also: 1827017

Yep, it's fixed.

Status: NEW → RESOLVED
Closed: 1 year ago
Duplicate of bug: 1827337
Flags: needinfo?(mozilla)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: