Closed Bug 1824156 Opened 11 months ago Closed 9 months ago

Migrate mail-bar3 contents to mail space unified toolbar

Categories

(Thunderbird :: Toolbars and Tabs, task, P1)

Unspecified
All

Tracking

(thunderbird_esr102 unaffected, thunderbird111 wontfix, thunderbird112+ wontfix, thunderbird113 wontfix, thunderbird114+ fixed)

RESOLVED FIXED
115 Branch
Tracking Status
thunderbird_esr102 --- unaffected
thunderbird111 --- wontfix
thunderbird112 + wontfix
thunderbird113 --- wontfix
thunderbird114 + fixed

People

(Reporter: freaktechnik, Assigned: freaktechnik)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Supernova3p])

Attachments

(2 files)

For continuity we want to migrate the contents of the mail tab toolbar (as well as contents of the global areas) to the unified toolbar mail space.

Other toolbars will be addressed later on.

Whiteboard: [Supernova]

We will need someone to devise a command string to force a migration, for users who want to overwrite the current toolbar settings. The team discussed providing such an option, because the migration is designed to not happen if the user has already customize the toolbar, i.e. avoids destroying anything the user has customized in supernova.

Attachment #9324692 - Attachment description: Bug 1824156 - Migrate mail tab toolbar to unified toolbar. r=#thunderbird-front-end-reviewers → WIP: Bug 1824156 - Migrate mail tab toolbar to unified toolbar. r=#thunderbird-front-end-reviewers
Attachment #9324692 - Attachment description: WIP: Bug 1824156 - Migrate mail tab toolbar to unified toolbar. r=#thunderbird-front-end-reviewers → Bug 1824156 - Migrate mail tab toolbar to unified toolbar. r=#thunderbird-front-end-reviewers
Whiteboard: [Supernova] → [Supernova3p]

I somehow missed adding this to our priority list, since it is wanted for the beta appeal.

Severity: -- → S3
Flags: needinfo?(alessandro)
Priority: -- → P1

This was brought to completion by John so he's the one that should confirm if it's ready to land.

Flags: needinfo?(alessandro) → needinfo?(john)

please also note comment 2 - it will be helpful to have a process so that testers can replicate migrations.

John,

So others understand, please confirm that for a new user profile, the migration will supply a mail toolbar with default buttons of get mail, write, tag, and quick filter (plus search and appmenu), per const XUL_TOOLBAR_DEFAULT_SET

I somehow missed adding this to our priority list, since it is wanted for the beta appeal.

Correction, "must have" for the beta appeal, which is hoped to be 1-2 weeks after 102.11.0 ships on May 9.

Related is this "ready to land", is whether there are any major functional issues still to be fixed in the toolbar?

Severity: S3 → S2

(In reply to Wayne Mery (:wsmwk) from comment #2)

We will need someone to devise a command string to force a migration, for users who want to overwrite the current toolbar settings. The team discussed providing such an option, because the migration is designed to not happen if the user has already customize the toolbar, i.e. avoids destroying anything the user has customized in supernova.

hmm, I've just read some comments in phab which make it sound like the migration cannot be rerun on the same profile
"Testing this is... interesting. Here's the "forced migration" function. Note that this can only work once, because we clear the xulstore values of the old mail tab toolbar after a migration."

After landing on c-c, this needs to go to beta. Wednesday's beta would be great.

(In reply to Wayne Mery (:wsmwk) from comment #5)

please also note comment 2 - it will be helpful to have a process so that testers can replicate migrations.

Further in comment 7, I confirmed with Alex that repeating the migration process using the same profile is not straight forward, because the old toolbar data is destroyed in the migration.

But the old toolbar data must be in a file that could be easily restored, like xulstore.json, rather than needing to restore an entire profile?

Flags: needinfo?(john) → needinfo?(mkmelin+mozilla)
Summary: Migrate mail-bar3 contents to mail space unified toolbar → Migrate mail-bar3 contents to mail space unified toolbar, and provide default mail toolbar buttons

(In reply to Wayne Mery (:wsmwk) from comment #8)

After landing on c-c, this needs to go to beta. Wednesday's beta would be great.

Flags: needinfo?(john)

(In reply to Wayne Mery (:wsmwk) from comment #9)

But the old toolbar data must be in a file that could be easily restored, like xulstore.json, rather than needing to restore an entire profile?

migrateToolbarForSpace will explicitly nuke the old data. Otherwise it would still be accessible so one could re-run migration. Not that re-running migration is generally advisable. The code would then have to account for such things. But if we're not going to migrate into an already customized toolbar anyway => I'm assuming re-migration wouldn't do anything.

Flags: needinfo?(mkmelin+mozilla)
Blocks: 1829911
Flags: needinfo?(john)

I rebased the patch and issued a try run:
https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=8ab0e3d74265795f8268d831d8bbd8049930f253

I manually upgrade the following profiles:

  1. 102 profile with customizations to tip - migration success
  2. 102 profile with customization to 114 (no buttons visible) and then to tip - migration success
  3. 102 profile without customization to tip - migration success (defaults)
  4. 102 profile without customization to 114 (no buttons visible) and then to tip - migration success (defaults)
Target Milestone: --- → 115 Branch

Pushed by solange@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/e11b8f81602a
Migrate mail tab toolbar to unified toolbar. r=darktrojan,aleca
https://hg.mozilla.org/comm-central/rev/37e6c13c9700
Fix OSX tests for toolbar migration. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Depends on: 1834241

I had intended to land this on beta, but upon discovering bug 1834241 - which was the overwhelming reason for wanting this on beta - I balked. Also, I didn't know whether Martin would want to reopen this bug or do the fix in bug 1834241.

Comment on attachment 9324692 [details]
Bug 1824156 - Migrate mail tab toolbar to unified toolbar. r=#thunderbird-front-end-reviewers

[Triage Comment]
Approved for beta.
It has been clarified that the migration does not provide defaults.

Attachment #9324692 - Flags: approval-comm-beta+

Comment on attachment 9334600 [details]
Bug 1824156 - Fix OSX tests for toolbar migration. r=aleca

[Triage Comment]
Approved for beta.

Attachment #9334600 - Flags: approval-comm-beta+
Summary: Migrate mail-bar3 contents to mail space unified toolbar, and provide default mail toolbar buttons → Migrate mail-bar3 contents to mail space unified toolbar
You need to log in before you can comment on or make changes to this bug.